# troubleshooting

**URL:** https://forum.storj.io/c/engineer-amas/dev-troubleshooting/19.md

[Latest](https://forum.storj.io/latest.md) · [Categories](https://forum.storj.io/categories.md) · [Tags](https://forum.storj.io/tags.md)

---

## [About the troubleshooting category](https://forum.storj.io/t/about-the-troubleshooting-category/58)

<div class="topic-metadata">

**Author:** [@jocelyn](https://forum.storj.io/u/jocelyn)\
**Replies:** 0

</div>

For Developers! Having issues with bindings, API, access keys, or uploading to buckets? Post here.

---

## [Gateway-mt: satellite startup-check timeout doesn't stop the process — hangs forever if satellite is down at boot](https://forum.storj.io/t/gateway-mt-satellite-startup-check-timeout-doesnt-stop-the-process-hangs-forever-if-satellite-is-down-at-boot/32707)

<div class="topic-metadata">

**Author:** [@kocoten1992](https://forum.storj.io/u/kocoten1992)\
**Replies:** 4\
**Last updated:** [September 18, 2026, 11:32pm UTC](https://forum.storj.io/t/gateway-mt-satellite-startup-check-timeout-doesnt-stop-the-process-hangs-forever-if-satellite-is-down-at-boot/32707 "2026-09-18T23:32:46Z")

</div>

I notice this while ago in Tutorial: Edge gateway-mt: INFO startupcheck/startupcheck.go:45 checking "\<sat\_address\>" # will stuck at checking satellite step forever.. INFO httpserver/server.go:320 …

---

## [Https://stats.storjshare.io/nodes.json is not updating?](https://forum.storj.io/t/https-stats-storjshare-io-nodes-json-is-not-updating/32697)

<div class="topic-metadata">

**Author:** [@Vadim](https://forum.storj.io/u/Vadim)\
**Replies:** 9\
**Last updated:** [September 10, 2026, 3:20pm UTC](https://forum.storj.io/t/https-stats-storjshare-io-nodes-json-is-not-updating/32697 "2026-09-10T15:20:15Z")

</div>

Does stats.storjshare.io/nodes.json not updating? several days Active nodes number is the same it is just not possible.

---

## [Error listing objects - "listing too many items for gateway-side filtering"](https://forum.storj.io/t/error-listing-objects-listing-too-many-items-for-gateway-side-filtering/30296)

<div class="topic-metadata">

**Author:** [@mpw](https://forum.storj.io/u/mpw)\
**Replies:** 19\
**Last updated:** [March 14, 2026, 8:15pm UTC](https://forum.storj.io/t/error-listing-objects-listing-too-many-items-for-gateway-side-filtering/30296 "2026-03-14T20:15:33Z")

</div>

Hi everyone! I’ve been using Storj (among many other things) as a backend for Kopia (a backup service; https://kopia.io/) for quite a while now. I’ve backed up large amounts of data with many snapshots over the course o…

---

## [Confusion on Account Billing](https://forum.storj.io/t/confusion-on-account-billing/31508)

<div class="topic-metadata">

**Author:** [@kbch](https://forum.storj.io/u/kbch)\
**Replies:** 2\
**Last updated:** [March 8, 2026, 3:18pm UTC](https://forum.storj.io/t/confusion-on-account-billing/31508 "2026-03-08T15:18:19Z")

</div>

My Billing happens with Funds, which originate from STORJ tokens. Checking the invoices from the last months, there is always a position “Prior Stripe Customer Balance”. This seems some sort of carry over from the last …

---

## [Consistent "MissingContentLength" Error with S3 Gateway (Boto3 & AWS CLI)](https://forum.storj.io/t/consistent-missingcontentlength-error-with-s3-gateway-boto3-aws-cli/30768)

<div class="topic-metadata">

**Author:** [@eef-or-th](https://forum.storj.io/u/eef-or-th)\
**Replies:** 1\
**Last updated:** [September 13, 2025, 10:23pm UTC](https://forum.storj.io/t/consistent-missingcontentlength-error-with-s3-gateway-boto3-aws-cli/30768 "2025-09-13T22:23:55Z")

</div>

Subject: S3 MissingContentLength Error with Storj Gateway Using Boto3 and AWS CLI Hi everyone, I’m encountering a persistent “MissingContentLength” error when attempting to upload files to the Storj S3 gateway (gateway.…

---

## [X-amz-content-sha256 Header Mismatch When Uploading Objects to Kerberos Vault](https://forum.storj.io/t/x-amz-content-sha256-header-mismatch-when-uploading-objects-to-kerberos-vault/29667)

<div class="topic-metadata">

**Author:** [@javertiz](https://forum.storj.io/u/javertiz)\
**Replies:** 4\
**Last updated:** [April 3, 2025, 3:34am UTC](https://forum.storj.io/t/x-amz-content-sha256-header-mismatch-when-uploading-objects-to-kerberos-vault/29667 "2025-04-03T03:34:28Z")

</div>

We’re encountering an authentication error while trying to upload files to Storj via the S3-compatible API from a self-hosted Kerbero Vault. The error occurs consistently during object uploads, and we’d appreciate your g…

---

## [Directory listing using Filezilla stopped working](https://forum.storj.io/t/directory-listing-using-filezilla-stopped-working/16046)

<div class="topic-metadata">

**Author:** [@Barukimang](https://forum.storj.io/u/Barukimang)\
**Replies:** 7\
**Last updated:** [March 5, 2025, 12:26pm UTC](https://forum.storj.io/t/directory-listing-using-filezilla-stopped-working/16046 "2025-03-05T12:26:28Z")

</div>

Am getting the following error: Error: Failed to retrieve directory listing Status: Disconnected from server Status: Connecting to eu1.storj.io… Status: Retrieving directory listing of /admin… Command: lis…

---

## [Cannot upload file with aws-cli](https://forum.storj.io/t/cannot-upload-file-with-aws-cli/29374)

<div class="topic-metadata">

**Author:** [@tushar-saxena-yral](https://forum.storj.io/u/tushar-saxena-yral)\
**Replies:** 9\
**Last updated:** [February 28, 2025, 3:18am UTC](https://forum.storj.io/t/cannot-upload-file-with-aws-cli/29374 "2025-02-28T03:18:08Z")

</div>

I am unable to upload files to storj with neither gateway-mt nor gateway-st using aws-cli. I have two instances of gateway-st running, 1. locally, 2. remotely on fly. They are all backed by the same account. However, I …

---

## [PutObject fails when going through self-hosted gateway-st](https://forum.storj.io/t/putobject-fails-when-going-through-self-hosted-gateway-st/28942)

<div class="topic-metadata">

**Author:** [@tushar-saxena-yral](https://forum.storj.io/u/tushar-saxena-yral)\
**Replies:** 10\
**Last updated:** [February 25, 2025, 10:27am UTC](https://forum.storj.io/t/putobject-fails-when-going-through-self-hosted-gateway-st/28942 "2025-02-25T10:27:34Z")

</div>

I have setup gateway-st and i can confirm that the setup is working properly as i can list buckets and see all my buckets. However, when i try to put objects I get an error on the client side: dispatch failure Details…

---

## [Installing storj test network on windows](https://forum.storj.io/t/installing-storj-test-network-on-windows/28859)

<div class="topic-metadata">

**Author:** [@Tarun786](https://forum.storj.io/u/Tarun786)\
**Replies:** 12\
**Last updated:** [December 22, 2024, 1:42pm UTC](https://forum.storj.io/t/installing-storj-test-network-on-windows/28859 "2024-12-22T13:42:02Z")

</div>

I am trying to install storj test network on windows system but i am getting this error when i am running go install ./…

---

## [\[Duplicati\] not possible connecting to a bucket using API Key (CLI) to perform a backup](https://forum.storj.io/t/duplicati-not-possible-connecting-to-a-bucket-using-api-key-cli-to-perform-a-backup/19818)

<div class="topic-metadata">

**Author:** [@anon16730638](https://forum.storj.io/u/anon16730638)\
**Replies:** 12\
**Last updated:** [November 3, 2024, 5:38pm UTC](https://forum.storj.io/t/duplicati-not-possible-connecting-to-a-bucket-using-api-key-cli-to-perform-a-backup/19818 "2024-11-03T17:38:47Z")

</div>

I downloaded the canary version of Duplicati as indicated in your documentation Backup With Duplicati | Storj Docs, the version I installed is v2.0.6.104-2.0. 6.104\_canary\_2022-06-15 (but the problem also occurs with pre…

---

## [Storagenode Setup](https://forum.storj.io/t/storagenode-setup/28120)

<div class="topic-metadata">

**Author:** [@ptdatta](https://forum.storj.io/u/ptdatta)\
**Replies:** 3\
**Last updated:** [October 3, 2024, 5:34am UTC](https://forum.storj.io/t/storagenode-setup/28120 "2024-10-03T05:34:01Z")

</div>

What is the proper way to setup storagenode? I binded the UI with my docker container. volumes: - type: bind source: ./web/storagenode target: /var/lib/storj/web/storagenode bind: {} On storj-up…

---

## [Custom domain setup impossible to get working](https://forum.storj.io/t/custom-domain-setup-impossible-to-get-working/27905)

<div class="topic-metadata">

**Author:** [@Kris](https://forum.storj.io/u/Kris)\
**Replies:** 6\
**Last updated:** [September 17, 2024, 4:40am UTC](https://forum.storj.io/t/custom-domain-setup-impossible-to-get-working/27905 "2024-09-17T04:40:34Z")

</div>

Hi I’m trying to get a custom domain to work for my bucket but after hours of trying it just does not seem to work. I followed the docs as closely as possible alongside the youtube walkthrough but it’s just not coming t…

---

## [Setting Storj Locally](https://forum.storj.io/t/setting-storj-locally/27593)

<div class="topic-metadata">

**Author:** [@ptdatta](https://forum.storj.io/u/ptdatta)\
**Replies:** 16\
**Last updated:** [August 28, 2024, 10:30am UTC](https://forum.storj.io/t/setting-storj-locally/27593 "2024-08-28T10:30:16Z")

</div>

I am trying to set up Storj locally to make OSS contributions. So after forking and cloning I set up storj-up and spin up all the containers. Then created an identity certificate and key and run satellite setup followe…

---

## [Storj hosted API Endpoint gone ? 404 Object not Found](https://forum.storj.io/t/storj-hosted-api-endpoint-gone-404-object-not-found/27002)

<div class="topic-metadata">

**Author:** [@CutieePie](https://forum.storj.io/u/CutieePie)\
**Replies:** 4\
**Last updated:** [July 12, 2024, 8:35am UTC](https://forum.storj.io/t/storj-hosted-api-endpoint-gone-404-object-not-found/27002 "2024-07-12T08:35:14Z")

</div>

Not sure if this is the correct place, I’ve not seen any posts about the endpoint being pulled, however the forum is so full of OT posts it’s hard to keep track… Happy to put an issue on Github if needed… One of the St…

---

## [Error while uploading large files via django-storages](https://forum.storj.io/t/error-while-uploading-large-files-via-django-storages/18259)

<div class="topic-metadata">

**Author:** [@samuel](https://forum.storj.io/u/samuel)\
**Replies:** 4\
**Last updated:** [July 7, 2024, 3:53pm UTC](https://forum.storj.io/t/error-while-uploading-large-files-via-django-storages/18259 "2024-07-07T15:53:41Z")

</div>

I am using Storj for serving and storing my static and media content for a Django project. For interacting with Storj buckets I am using django-storages. I am facing no problem while uploading small file (~10 MB), howeve…

---

## [Cannot login into ap1.storj.io got error "HCaptcha is required"](https://forum.storj.io/t/cannot-login-into-ap1-storj-io-got-error-hcaptcha-is-required/24701)

<div class="topic-metadata">

**Author:** [@bebeo92](https://forum.storj.io/u/bebeo92)\
**Replies:** 18\
**Last updated:** [July 1, 2024, 7:15am UTC](https://forum.storj.io/t/cannot-login-into-ap1-storj-io-got-error-hcaptcha-is-required/24701 "2024-07-01T07:15:41Z")

</div>

Hi like the title, I try to access my backup data via website And I got this error which is weird and don’t know how to handle it

---

## [Web worker is not initialized](https://forum.storj.io/t/web-worker-is-not-initialized/26619)

<div class="topic-metadata">

**Author:** [@iotces1](https://forum.storj.io/u/iotces1)\
**Replies:** 1\
**Last updated:** [June 13, 2024, 2:51pm UTC](https://forum.storj.io/t/web-worker-is-not-initialized/26619 "2024-06-13T14:51:51Z")

</div>

Web worker is not initialized. Browser console is reporting an error: Failed to fetch wasm manifest.

---

## [Upload with S3 compatible Api on rclone failed](https://forum.storj.io/t/upload-with-s3-compatible-api-on-rclone-failed/26539)

<div class="topic-metadata">

**Author:** [@joe83](https://forum.storj.io/u/joe83)\
**Replies:** 1\
**Last updated:** [June 9, 2024, 5:03pm UTC](https://forum.storj.io/t/upload-with-s3-compatible-api-on-rclone-failed/26539 "2024-06-09T17:03:49Z")

</div>

when I upload file size greater than 150GB with S3 compatible API, the progress only showing max 325MB, any resolution. for this I don’t use Access grant to reduce the upload bandwith. thanks

---

## [I can't able to access public uploaded file via link](https://forum.storj.io/t/i-cant-able-to-access-public-uploaded-file-via-link/26418)

<div class="topic-metadata">

**Author:** [@foreverfree100](https://forum.storj.io/u/foreverfree100)\
**Replies:** 5\
**Last updated:** [June 6, 2024, 2:41pm UTC](https://forum.storj.io/t/i-cant-able-to-access-public-uploaded-file-via-link/26418 "2024-06-06T14:41:26Z")

</div>

Hey StorJ Team, I can’t access the publicly uploaded file through the link. We are using uplink-nodejs library in our code. A new access token is generated when we upload files. So can you please help with this. let me …

---

## [S3 Region: Virtual Hosted-Style: invalid region not valid DNS](https://forum.storj.io/t/s3-region-virtual-hosted-style-invalid-region-not-valid-dns/25313)

<div class="topic-metadata">

**Author:** [@jason-warner](https://forum.storj.io/u/jason-warner)\
**Replies:** 6\
**Last updated:** [March 16, 2024, 9:01am UTC](https://forum.storj.io/t/s3-region-virtual-hosted-style-invalid-region-not-valid-dns/25313 "2024-03-16T09:01:53Z")

</div>

My use case is just creating a bucket to be used with Obsidian sync. I encountered an issue upon configuration that I was unable to find any relevant information or solutions on the internet. This appears to be a bug wi…

---

## [Installation of uplink\_python Dependencies Fails \[Windows 10\]](https://forum.storj.io/t/installation-of-uplink-python-dependencies-fails-windows-10/24961)

<div class="topic-metadata">

**Author:** [@ponysrc](https://forum.storj.io/u/ponysrc)\
**Replies:** 6\
**Last updated:** [March 24, 2024, 4:44am UTC](https://forum.storj.io/t/installation-of-uplink-python-dependencies-fails-windows-10/24961 "2024-03-24T04:44:14Z")

</div>

Hi, I’m new to this forum. I’ve been following the directions in the Github uplink-python binding readme, because I am trying to install the uplink\_python module. The pip installation method appeared to succeed, but fail…

---

## [Self-hosted gateway error](https://forum.storj.io/t/self-hosted-gateway-error/25288)

<div class="topic-metadata">

**Author:** [@ZhiYuan](https://forum.storj.io/u/ZhiYuan)\
**Replies:** 2\
**Last updated:** [February 23, 2024, 4:39am UTC](https://forum.storj.io/t/self-hosted-gateway-error/25288 "2024-02-23T04:39:58Z")

</div>

any one knows what this errors means? API: SYSTEM() Time: 22:02:14 +08 02/21/2024 DeploymentID: 986fb67a-0976-4b0a-adcf-cb973ca61f8c Error: (cmd.NotImplemented) 5: \\go\\pkg\\mod\\storj.io\\minio@v0.0.0-20230627070725-3…

---

## [I am storj customer who is using it to store videos on my website (By using static website) but range header response is not consistent](https://forum.storj.io/t/i-am-storj-customer-who-is-using-it-to-store-videos-on-my-website-by-using-static-website-but-range-header-response-is-not-consistent/25052)

<div class="topic-metadata">

**Author:** [@angelkeysfordns](https://forum.storj.io/u/angelkeysfordns)\
**Replies:** 2\
**Last updated:** [January 31, 2024, 7:54pm UTC](https://forum.storj.io/t/i-am-storj-customer-who-is-using-it-to-store-videos-on-my-website-by-using-static-website-but-range-header-response-is-not-consistent/25052 "2024-01-31T19:54:15Z")

</div>

I realized that when we are using static website feature to serve contents of bucket to users on internet ‘range’ header is generally respected but it does not seem to be consistent. Sometimes I get 200 OK full response …

---

## [Slow upload with Rclone Gateway MT](https://forum.storj.io/t/slow-upload-with-rclone-gateway-mt/24827)

<div class="topic-metadata">

**Author:** [@thomas-rd](https://forum.storj.io/u/thomas-rd)\
**Replies:** 4\
**Last updated:** [January 4, 2024, 3:19pm UTC](https://forum.storj.io/t/slow-upload-with-rclone-gateway-mt/24827 "2024-01-04T15:19:51Z")

</div>

I am testing out Storj, following the advice in Hotrodding Decentralized Storage. I have a 10G test file and have configured rclone with a native config and a Gateway MT config on a GCP instance with 12 vCPUs and 16GB of…

---

## [TLS not working for custom domain](https://forum.storj.io/t/tls-not-working-for-custom-domain/23830)

<div class="topic-metadata">

**Author:** [@mitexleo](https://forum.storj.io/u/mitexleo)\
**Replies:** 4\
**Last updated:** [December 8, 2023, 8:22am UTC](https://forum.storj.io/t/tls-not-working-for-custom-domain/23830 "2023-12-08T08:22:25Z")

</div>

Hi everyone, TLS is not working for my domain “cdn.buddyverse.xyz” despite upgrading the the account to pro tier. My DNS Settings: Thanks

---

## [Link generated in linksharing works only on the PC where it was generated](https://forum.storj.io/t/link-generated-in-linksharing-works-only-on-the-pc-where-it-was-generated/24502)

<div class="topic-metadata">

**Author:** [@munjalp](https://forum.storj.io/u/munjalp)\
**Replies:** 1\
**Last updated:** [November 29, 2023, 4:38am UTC](https://forum.storj.io/t/link-generated-in-linksharing-works-only-on-the-pc-where-it-was-generated/24502 "2023-11-29T04:38:10Z")

</div>

Hi, In the linksharing, the link is getting generated but it is not opening in other PCs. Is there any configuration which may be missing?

---

## [Issues connecting to the gateway](https://forum.storj.io/t/issues-connecting-to-the-gateway/24424)

<div class="topic-metadata">

**Author:** [@gabriel](https://forum.storj.io/u/gabriel)\
**Replies:** 3\
**Last updated:** [November 22, 2023, 7:40am UTC](https://forum.storj.io/t/issues-connecting-to-the-gateway/24424 "2023-11-22T07:40:51Z")

</div>

Hello. I’ve recently started having an issue connecting to the S3 gateway from some of my servers, the connection just timeouts. Some servers are still able to connect; is it possible that some of my IPs are blocked by t…

---

## [Slow TLS handshake](https://forum.storj.io/t/slow-tls-handshake/24206)

<div class="topic-metadata">

**Author:** [@pwilczynski](https://forum.storj.io/u/pwilczynski)\
**Replies:** 5\
**Last updated:** [October 30, 2023, 6:04pm UTC](https://forum.storj.io/t/slow-tls-handshake/24206 "2023-10-30T18:04:56Z")

</div>

Any idea why it takes 10-15seconds at TLS negotiation phase? time curl -vL https://gateway.storjshare.io/ 0.01s user 0.01s system 0% cpu 12.865 total Status page doesn’t show any issues? https://status.storj.io/

[Next page](https://forum.storj.io/c/engineer-amas/dev-troubleshooting/19.md?page=1)
