Announcement: Storj to shut down europe-north-1 and us2

Also it use 8TB of my space, but looks like storj dont pay for it any more or I mistaken somewhere?
I would like to free it as soon as possible in this case. it just not professional from storj to ocupy space, not pay for it and letting people so long wait with information about how to delete it as was announced 2 months ago.

1 Like

I would guess with the next payment.

We have a change on the way that will allow SNOs to be able to easily cleanup the satellite data and avoid any annoying errors in logs https://review.dev.storj.io/c/storj/storj/+/10876. This should hopefully, be part of the next release.

Once this is merged and rolled-out, we will post a how-to guide on the forum and docs.storj.io.

13 Likes

Oooo, I thoud that it will be manual cleaning or something like that. As there is some new development for automation, now it make sense.
Thanks for update.

2 Likes

At first glance this command seems to convey that all satellites will be “forgotten” ergo a clean slate.

$ storagenode forget-satellite --all --identity-dir /path/to/identityDir --config-dir /path/to/configDir

Ref: https://review.dev.storj.io/c/storj/storj/+/10876/13/cmd/storagenode/cmd_forget_satellite.go#49

Would calling the flag --alluntrusted be an option? So it would look like

$ storagenode forget-satellite –alluntrusted --identity-dir /path/to/identityDir --config-dir /path/to/configDir

1 Like

Can you provide the exact command in the config-file?

Edit: How to add multiple sattelites?

storage2.trust.exclusions: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE@saltlake.tardigrade.io:7777”

This works, but adding second sattelite with ; or , doesnt work. Space character also not working.

It definitely works with comma without space after it. I coped my own parameter from the one of the nodes:

However make sure to do not use a curly quotes: and , use only straight ones: ".
But I guess you want to exclude Europe-North-1 and US2, not Saltlake.

Please provide your parameter between two new lines with three backticks, like this:

```
storage2.trust.exclusions:
```

Saltlake as well as I have GE on it as well.

Now it looks fine:

When the node does get restart im getting WARN messages for all three sattelites, that console: sevice unable to get Sattelite URL. Is there a possibility to solve this WARN message?

There is no way to get rid of that warning message. Also since its a WARNing message you can safely ignore it.

Yes, wait for release of the feature:

and then call it, as would be described in the documentation.

1 Like

There is one: set the log level to FATAL. :sweat_smile:

1 Like

Thanks for the suggestion. This is will be considered

3 Likes

Объясните пожалуйста. Я так и не понял, нужно ли мне, как оператору, совершать какие либо действия с узлами для освобождения места от удаленных спутников?
Спутники не активны, в панели управления показывает что данных по ним нет, но в реальности Blobs папки этих спутников содержат много данных. Что с этим делать? Прописывать “storage2.trust.exclusions”, удалять вручную папки или еще что? Объясните пожалуйста алгоритм действий

Do you know if/when heldback for deleted sats will be paid?

1 Like

A date has not been assigned yet.
When the date is calendared, it will be posted.

We are waiting for instructions to be published. Right now you does not need to do anything.

нв русском

Мы ожидаем, когда инструкции будут опубликованы. Прямо сейчас делать ничего не нужно.
Дата публикации пока неизвестна. Ожидаем, когда этот PR будет выпущен в релиз:

Announcement: Storj to shut down europe-north-1 and us2 - #81 by clement

3 Likes

Finally! How To Forget Untrusted Satellites

11 Likes


Farewell, europe-north-1 and us2. It’s been fun!

7 Likes