Authorize storagenode command taking hours to complete - doesn't finish

I am following the steps at
to create and sign the identity, so I can do a Windows Gui install node.

I get through the “create identity” step with now problem.

When I enter the authorize storagenode command with my authorization token, it never completes - no error. I’m waiting hours and don’t see it completing. I have cancelled and restarted it several times. Should it take that long? I will allow it to work overnight, but does this indicate a problem with my token?

Thank you


Depending on cpu and just pure luck, it can go super fast or take some hours to complete

Hello @texas,
Welcome to the forum!

if you have < or > in the command, please, remove them. There is should be no quotes too

Hi Alexey,

No using < or > in the command, or quotes. Here’s what I’m running, see screenshot below. It just hangs like that for hours, even a day. So, I don’t ever get the 6 needed files in the storagenode folder, only the 4…

Is it possible I need a new auth key?

Your user should have full rights to the c:\identity-creator folder (it will create a revocation.db here)

I gave explicit full control to my user, and also to the Everyone group, but still get the same result. The command just hangs, running forever.

Can I get a new unique token to try, or do you have any other ideas?

Thank you

Please, allow the identity_windows_amd64.exe in the firewall to access the internet

Please, open a powershell and execute:

ls c:\identity-creator 
Unblock-File c:\identity-creator\identity_windows_amd64.exe

Then try again

3 posts were merged into an existing topic: Certificates peer error

A post was merged into an existing topic: Certificates peer error