# Cant get new node running

**URL:** <https://forum.storj.io/t/cant-get-new-node-running/7556>\
**Category:** troubleshooting\
**Tags:** windows-gui, identity, windows, offline\
**Created:** [June 14, 2020, 12:10pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556 "2020-06-14T12:10:58Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mikey89](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/mikey89/32/1138_2.png) [@Mikey89](https://forum.storj.io/u/Mikey89)\
**Post date:** [June 14, 2020, 12:10pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/1 "2020-06-14T12:10:58Z")

</div>

Can somebody help me get my node up and running after i had a hard drive failure?

I installed a new node and getting this message.

ERROR nodestats:cache Get stats query failed {“error”: “context canceled”}  
2020-06-14T08:09:10.113-0400 FATAL Unrecoverable error {“error”: “debug: http: Server closed”, “errorVerbose”: “debug: http: Server closed\n\[tstorj.io/private/debug.(\*Server](http://tstorj.io/private/debug.(*Server)).Run.func2:108\n\[tgolang.org/x/sync/errgroup.(\*Group](http://tgolang.org/x/sync/errgroup.(*Group)).Go.func1:57”}

---

<div class="post-metadata">

**Author:** ![nerdatwork](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/nerdatwork/32/1135_2.png) [@nerdatwork](https://forum.storj.io/u/nerdatwork)\
**Post date:** [June 14, 2020, 12:31pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/2 "2020-06-14T12:31:12Z")

</div>

Is it Windows or Linux ? GUI or docker ?

---

<div class="post-metadata">

**Author:** ![digitalfrank](https://storj.bcdn.literatehosting.com/letter_avatar/digitalfrank/32/5_5575768a8748004e209b776fc1b2916d.png) [@digitalfrank](https://forum.storj.io/u/digitalfrank)\
**Post date:** [June 14, 2020, 12:39pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/3 "2020-06-14T12:39:25Z")

</div>

it happens to me too. every time I restart the service on windows 10. it is an installation with gui no docker. I have no other problems nor db or other fail. I just want to point out that in the log the error is not reported as ERROR

Edit:  
it happens when I shutdown the service.  
I checked the log now

2020-06-01T19:56:39.783+0200 INFO Stop/Shutdown request received.  
2020-06-01T19:56:39.956+0200 FATAL Unrecoverable error {“error”: “debug: http: Server closed”, “errorVerbose”: “debug: http: Server closed\n\[tstorj.io/private/debug.(\*Server](http://tstorj.io/private/debug.(*Server)).Run.func2:108\n\[tgolang.org/x/sync/errgroup.(\*Group](http://tgolang.org/x/sync/errgroup.(*Group)).Go.func1:57”}  
2020-06-01T19:56:44.585+0200 INFO Configuration loaded {“Location”: “C:\Program Files\Storj\Storage Node\config.yaml”}

---

<div class="post-metadata">

**Author:** ![Mikey89](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/mikey89/32/1138_2.png) [@Mikey89](https://forum.storj.io/u/Mikey89)\
**Post date:** [June 14, 2020, 1:15pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/4 "2020-06-14T13:15:13Z")

</div>

Windows 10 GUI

thank you so much to anybody who helps

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [June 14, 2020, 1:35pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/5 "2020-06-14T13:35:28Z")

</div>

Please, show the result of the command (Powershell)

```auto
Get-Service storagenode*

```

Is your node online? If the services above are running, then I would like to recommend you to check your configuration with this checklist:

> [@My Node is OFFLINE for 2 hours](https://forum.storj.io/t/736/2):
>
> It should connect in seconds. There are a few things you should check. Start with checking the port. On [https://www.yougetsignal.com/tools/open-ports/?port=28967](https://www.yougetsignal.com/tools/open-ports/?port=28967) you can fill in the domain or IP you are using in the run command. Then check the port. If it’s closed, it could still be several things. Make sure the WAN IP you see in your router settings matches the IP shown on the above page. Make sure your port forward is set up correctly. That means no filter on incoming IPs, forwarding to th…

---

<div class="post-metadata">

**Author:** ![Mikey89](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/mikey89/32/1138_2.png) [@Mikey89](https://forum.storj.io/u/Mikey89)\
**Post date:** [June 14, 2020, 1:35pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/6 "2020-06-14T13:35:58Z")

</div>

Running storagenode Storj V3 Storage Node  
Running storagenode-upd… Storj V3 Storage Node Updater

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [June 14, 2020, 1:36pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/7 "2020-06-14T13:36:36Z")

</div>

> [@digitalfrank](#):
>
> 2020-06-01T19:56:39.956+0200 FATAL Unrecoverable error {“error”: “debug: http: Server closed”, “errorVerbose”: “debug: http: Server closed\n[tstorj.io/private/debug.(\*Server]([http://tstorj.io/private/debug.(\*Server)](http://tstorj.io/private/debug.(*Server))).Run.func2:108\n[tgolang.org/x/sync/errgroup.(\*Group]([http://tgolang.org/x/sync/errgroup.(\*Group)](http://tgolang.org/x/sync/errgroup.(*Group))).Go.func1:57”}  
> 2020-06-01T19:56:44.585+0200 INFO Configuration loaded {“Location”: “C:\Program Files\Storj\Storage Node\config.yaml”}

Is your node running after that?

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [June 14, 2020, 1:37pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/8 "2020-06-14T13:37:14Z")

</div>

If your node OFFLINE, then please, check your configuration with checklist

> [@My Node is OFFLINE for 2 hours](https://forum.storj.io/t/736/2):
>
> It should connect in seconds. There are a few things you should check. Start with checking the port. On [https://www.yougetsignal.com/tools/open-ports/?port=28967](https://www.yougetsignal.com/tools/open-ports/?port=28967) you can fill in the domain or IP you are using in the run command. Then check the port. If it’s closed, it could still be several things. Make sure the WAN IP you see in your router settings matches the IP shown on the above page. Make sure your port forward is set up correctly. That means no filter on incoming IPs, forwarding to th…

---

<div class="post-metadata">

**Author:** ![Mikey89](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/mikey89/32/1138_2.png) [@Mikey89](https://forum.storj.io/u/Mikey89)\
**Post date:** [June 14, 2020, 1:47pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/9 "2020-06-14T13:47:05Z")

</div>

My ID wasn’t signed. LOL THNX PPL

---

<div class="post-metadata">

**Author:** ![digitalfrank](https://storj.bcdn.literatehosting.com/letter_avatar/digitalfrank/32/5_5575768a8748004e209b776fc1b2916d.png) [@digitalfrank](https://forum.storj.io/u/digitalfrank)\
**Post date:** [June 14, 2020, 3:04pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/10 "2020-06-14T15:04:20Z")

</div>

> [@Alexey](#):
>
> Is your node running after that?

Of course, I have no mistakes. It restarts and continues without errors. Audits, egress, ingress and more. For two months now I have 3 nodes and also I am already updated to 1.6.3 on all three.

---

<div class="post-metadata">

**Author:** ![digitalfrank](https://storj.bcdn.literatehosting.com/letter_avatar/digitalfrank/32/5_5575768a8748004e209b776fc1b2916d.png) [@digitalfrank](https://forum.storj.io/u/digitalfrank)\
**Post date:** [June 14, 2020, 6:36pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/11 "2020-06-14T18:36:12Z")

</div>

But i have a problems?

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [June 14, 2020, 6:49pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/12 "2020-06-14T18:49:26Z")

</div>

No, if your node is online, not suspended and not disqualified and its Audit score 100%, all working fine.  
I created an internal issue on any case with this bug, but seems it can be ignored at the moment.

---

<div class="post-metadata">

**Author:** ![digitalfrank](https://storj.bcdn.literatehosting.com/letter_avatar/digitalfrank/32/5_5575768a8748004e209b776fc1b2916d.png) [@digitalfrank](https://forum.storj.io/u/digitalfrank)\
**Post date:** [June 14, 2020, 7:30pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/13 "2020-06-14T19:30:35Z")

</div>

Thanks for reply.  
Yes, i have audit 100% and not i have others errors in the log.  
this errors, anyway, is occured from version 1.4.2.

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [September 8, 2020, 6:50pm UTC](https://forum.storj.io/t/cant-get-new-node-running/7556/14 "2020-09-08T18:50:17Z")

</div>

5 posts were split to a new topic: [In-memory buffer for uploads](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033)
