Docker client (watchtower) and server don't have same version

One of my nodes are running on an older End-of-Support Synology NAS which has an older version of Docker, no newer versions seem to be available. As a result the watchower which is a newer version keep stopping after a few seconds.
docker logs watchtower return the following:

level=fatal msg=“Error response from daemon: client and server don’t have same version (client : 1.24, server: 1.18)”

Anyone know if I can downrank watchtower to version 1.18?
Or does anyone else see another possible workaround?

Is it possible to install your own OS on that NAS? I have never used one, so not sure if it is possible.

I don’t think so.
But it might look like it is possible to change the version of Watchtower

COMPOSE_API_VERSION=auto (https://www.edureka.co/community/10699/error-saying-client-server-have-same-version-client-server)
But I can’t get it to work

A post was merged into an existing topic: StorJ version in windows is newer than in linux