Docker Image gateway

Hello I recognised that on Docker hub Docker images for the gateway and uplink. Are they working?

Hi jensamberg, Yes they are but you need to fetch the specific release tag rather than the latest image. See this doc for more info:

1 Like

@jennifer Thanks. Do you have an example command for me?

I tried this. However the container did not start
docker run --name=gateway storjlabs/gateway:f71bc3f-v1.0.0-go1.13.8

The container says

Select your satellite:
Enter number or satellite address as “@:” [1]: Enter your API key: Error: gateway setup error: API key cannot be empty

@jennifer I have the same problem as i had in I need help to acces ./gateway_linux_arm run outside my container

Can you pleas give me a hint how I configure the container tha I can access the gateway not only from local host?

Hey Jensamberg, let me try it out and get back to you.

Hi @jensamberg - thanks for waiting patiently! I tried this out myself and I get the same issue. That command should ask you for your API key after you select the satellite, but there was a change in this setup that introduced this bug. Please hang tight while we fix this issue. Thanks for bringing it to our attention too :slight_smile:

For now I would also suggest trying out the non-docker gateway setup
Let me know if that works.

@jennifer thanks non docker works. No problems. However I need to run it on my QNAP and I was able to configure it. Do you have a answer how I can configure the container not only listen to localhost ?

Hi @jensamberg good news! You just needed to add the -it flag to your docker run command. Sorry about the back and forth! docker run --name=gateway -it storjlabs/gateway:f71bc3f-v1.0.0-go1.13.8

Does this fix your QNAP use case?

@jennifer It fix it not at all. Now I can start up the container.

However I can not access the gateway from other location. The endpoint shall also be reachable outside the NAS


you have to configure your container to forward that port, just like the storagenode configuration. There is nothing to fix.

@kevink I forward the port 7777. But I have no acces from my PC. E.g my NAS have the IP
and I try to access from my PC via S3 Browser Tardigrade. But it does not work

if you forward port 7777 in docker like -p it should work. but I only know about normal docker, not qnap.

@kevink No doesn´t work. Mybee it is the same issue like here. I need help to acces ./gateway_linux_arm run outside my container . But how can I reconfigure the docker container thet the S§ gateway not only listen to localhost?

then you might need to edit that config.yaml inside the docker container.
You should get into the container with
docker exec -it gateway sh

You need to edit the config.yaml and change the address to
By default it only listens to local host, so port mapping on the container alone isn’t enough.

Or specify the --server.address=":7777" after the image name in the docker run command

docker run -it -p 7777:7777 storjlabs/gateway:f71bc3f-v1.0.0-go1.13.8 --server.address=":7777"

Also, you can mount a config file to the container to do not configure the gateway every time


@Alexey Awesome this works. Thanks