Docker run command is not working

Was running nicely 2 days ago, today I noticed it’s not running.
Docker run command:
docker run -d --restart unless-stopped -p 28967:28967 -e WALLET=“0x0E670e84b6D11416A19602daA77d648fEfd42aaa” -e EMAIL="" -e ADDRESS=“” -e BANDWIDTH=“80TB” -e STORAGE=“3TB” --mount type=bind,source=“C:\Users\Kaevandus\AppData\Roaming\Storj\Identity\storagenode”,destination=/app/identity --mount type=bind,source=“E:\Storj\”,destination=/app/config --name storagenode storjlabs/storagenode:beta

C:\Program Files\Docker\Docker\Resources\bin\docker.exe: Error response from daemon: invalid mount config for type “bind”: stat /host_mnt/c/Users/Kaevandus/AppData/Roaming/Storj/Identity/storagenode: input/output error.
See ‘C:\Program Files\Docker\Docker\Resources\bin\docker.exe run --help’.

Hey @inz002

Your command has a few curly quotes instead of straight ones.

“” vs ""

This usually happens when you copy or edit commands in a word processor or apple notes etc. Make sure you only use text editors like notepad or code editors to save your commands. It should work after you replace the curly quotes.

Please, open a Docker desktop settings and clear selection of drives, click the “Apply”.
Then select drives “C” and “E” back, click “Apply” again. It could ask you for your Windows user and password, you must specify them, otherwise it will not work.
Your Windows user must have a password, otherwise Windows will not allow you to share a disk.

Regarding quotes, mentioned

You can remove all quotes at all to reduce a confusion. They are needed only if your paths contains spaces.