Downloading the Storage Node Docker Container

E:>docker pull storjlabs/storagenode:alpha
error during connect: Post http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.40/images/create?fromImage=storjlabs%2Fstoragenode&tag=alpha: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.

Please restart docker daemon from application, it will working

thank you, it worked now :stuck_out_tongue:

You are welcome! :slightly_smiling_face:

8 posts were split to a new topic: Docker run command

the command does not start “docker pull storjlabs/storagenode:alpha”

Hey @peter054 and welcome to the forums!

I recommend a reboot. It fixed similar issues with my PI. Worth a shot!

should this command run docker clien (dockercli.exe)?
my docker is installed in c: \ program files \ docker \ doker
then the command should be c: \ program files \ docker \ doker \ dockercli.exe
docker pull storjlabs / storagenode: alpha
right?

Have you followed all the steps for setting up docker for windows:

Yes, I did this guide, but stopped at this step. the command is not executed, nothing happens … also watched the video, but there is an example for the mac and everything works. I do not understand how to run this command.

Please actually click the link. That’s not the storage node instructions but docker installation instructions. It tells you exactly what you need to do to make docker work in powershell/cmd.

I did everything according to the instructions.

  1. Install Docker ОК
  2. Download the Identity Binary ОК
    а. Create an Identity ОК
    в. Sign the Identity ОК
    с. Download the Storage Node Docker Container - problem
    in the terminal I run the command - “docker pull storjlabs/storagenode:alpha”
    I get a message - “it is not an internal or external command”, or nothing is happening at all. what am I doing wrong?

It seems you STILL didn’t click the link that was provided. I’m going to try to copy the relevant steps you may have missed. Your issue is with docker, not with the storj software.

Start Docker Desktop for Windows
Docker does not start automatically after installation. To start it, search for Docker, select Docker Desktop for Windows in the search results, and click it (or hit Enter).

search for Docker app

When the whale in the status bar stays steady, Docker is up-and-running, and accessible from any terminal window.

If the whale is hidden in the Notifications area, click the up arrow on the taskbar to show it. To learn more, see Docker Settings.

docker was authorized and started immediately. maybe you need to do shared drives?
but I don’t have access for this.

you do need to share the drives you will use for your node. It requires the credentials for your windows account to access the drives.

However, this will not solve the issue of it not recognizing docker as a command. It should work automatically if docker is running.

docker is installed on c. in the terminal I need to specify the whole path or just specify c: \ docker pull storjlabs / storagenode: alpha

You don’t have to use a path at all. Just docker pull storjlabs/storagenode:alpha you have a lot of spaces in the command you posted that should not be there.

I created a container, but it turned out with errors.
I deleted all the container - docker ps -a -q.
then docker pull storjlabs / storagenode: alpha
then docker run -d --restart unless-stopped -p 28967: 28967 -e WALLET = "0x …
I get an error that the name is busy.
how to delete the container and create right again?

Thank you all very much, the node has earned

2 posts were split to a new topic: How to install storagenode on Windows Server 2016