Earnings calculator (Update 2022-12-08: v12.3.0 - Now compatible with node version 1.62+ - Detailed earnings info and health status of your node, including vetting progress)

As promised


v9.4.2 - Satellite us2 added

  • Added the us2 satellite name

Where’s the link?
Oh yes … 340 posts higher …
About 10 minutes of rewinding …

But it’s great that you still take care of this calculator :slight_smile:

1 Like

You need 10 minutes to get to the first post of a thread? :smiley:
Just grab the scrollbar on the right and move it upwards or remove the numbers from the link of the topic :wink:

1 Like

You can also click the topic title to take you straight to the top post. :slight_smile:

1 Like

I checked especially for you: it came out 6 minutes and 38 seconds - I scrolled with the mouse :slight_smile:
No online translation…
I have some old Celeron …
But BrightSilence’s advice worked, I didn’t know the way :slight_smile:

1 Like

@kevink was referring to this scroll bar.


Not your browsers scrollbar.

1 Like

Works too, great, thank you for the advice :slight_smile:

:rofl: Now I feel bad you used 6 minutes and 38 seconds of your precious time to test scrolling up this thread… But I hope that it was the last time you’ll ever do it on any discourse thread :smiley:

1 Like

You could also click the timestamp Sep 2019

And I also hope that someone else will use this information :slight_smile: and we will save a lot, a lot of time …


Hi! To find out what I can do, say @discobot display help.

1 Like

To be honest, it also took longer than I would like to admit for me to find out this could be done with the scroll bar. :slight_smile:

Same here, discovered this several months after I signed up… :sweat_smile:

Discourse is a great piece of software, once used to it :slight_smile:

1 Like

You can even do this on mobile, tap the post indicator [ xx / yyy ] and then you get the scroll bar. Not obvious but very helpful.

1 Like

The Home and End keys on my keyboard work even faster.

1 Like

When trying to run this on my QNAP NAS in the data dir I get this:

# python earnings.py
Traceback (most recent call last):
  File "earnings.py", line 231, in <module>
    con.execute('ATTACH DATABASE ? AS su;',tSU)
sqlite3.OperationalError: file is encrypted or is not a database

python -v says, after importing 20-odd modules (?):

Python 2.7.5 (default, Apr 22 2020, 02:53:40)
[GCC 4.5.4 20120201 (prerelease)] on linux2

Is it trying to run the (non-existent) su command, by chance?

I would like to suggest to run the script with sudo or check the databases, if it’s not the case:

If you’re checking db’s, specifically check the storage_usage.db as that’s what the script is trying to open at that point.

This isn’t related I think, but you should also really be switching to python 3.x at this point. Some systems that have both let you run python 3 .x by simply using python3 instead of python. You may need to separately install it on Qnap though. Not sure about that.

I’ve tried installing sudo, but it will not run. There is no root account, I log on as admin …

This version of python is part of the OS, so replacing it, even if it’s possible, could break things. Also, the next OS update will put things back the way they were. Does your script need v 3 in the near future? I can probably install it in addition to what QNAP have provided.

I have no experience with QNAP, but on Synology Python 3 is just available on the package center. I figured it would be the same on QNAP.

I’ve dropped testing on python 2 as it’s bee deprecated and no longer updated. I don’t see any reason why it won’t keep working, but no promises.

It’s been over a year now since it has been sunsetted. It’s time to make the switch. https://www.python.org/doc/sunset-python-2/