"Error response from daemon: invalid mount config for type" in Docker

I mean GUIDs of Windows accounts. The letter doesn’t matter since you use the correct one.
The permissions issue is related to Windows accounts only or hardware configuration.
And this error have proved it:

Please, try to do:

docker run -it --rm --entrypoint sh --mount type=bind,source=F:\,destination=/app/config storjlabs/storagenode

When you see prompt:

echo "test" > /app/config/storage/test.txt
cat /app/config/storage/test.txt
rm /app/config/storage/test.txt
exit

Please, post results

Before of Win reinstall I’ve used the Microsoft account (as proposal in installation proccess);
After reinstall the Microsoft account has disabled and I’ve moved to offline acc with different naming.

This is mean that the owner was different - from the initial account. And now you have all different and “nice” weirdness with permissions.

Current activity of 1st (working) node:

You missed > in the first command, please, try again

I hope you used a different disk for your second node.

yep,
there is two separate disks

Looks like the storage is writeable.

You did not answer on question:

This is weird question - because the node has been sets up before and works fine (before reboot => reinstall win).

there is always request for a reboot after update and there was not this reason for rebooting.
(I’ve just swaped the power supply and there was no emergency change).

Oh, you used a subfolder on disk, not the root of the disk.
Then we should repeat the test but for subfolder

docker run -it --rm --entrypoint sh --mount type=bind,source=F:\data,destination=/app/config storjlabs/storagenode

When you see a prompt, execute this:

echo "test" > /app/config/storage/test.txt
cat /app/config/storage/test.txt
rm /app/config/storage/test.txt
exit

Please, post results.


Should I mark this checkboxes?

Go to alternate way - moved the node to different place with GUI and default port 28967.
Now it began to works (at least shows up as ONLINE).
All what described and mentioned above runs me up in circles, the final result of restarting 2nd node that got issues after rebooting the pc I have not get. Hope that a part of this bad experience and waste of time of helpers and me can give some clue in issues of other operators.
Summary:

  1. Healthy node with Suspension/Audit/Online/=100% can hang about 10 days before disqualified;
  2. To expand the node quantity need to get up a Linyx system. All the Win configs with more than 1 node are pain in the ass;

Yes on both questions.

I have to agree, however if you remove the OWNER-CREATOR right away (I always do so for all new disks in my system), you will miss most of the pains with permissions. However, you always can fix it, but need more frictions.

By the way, you can get the same situation in Linux even simpler - run the docker container with sudo, then add your user to the docker group and run the same container without sudo - you will have the same problem with permissions.

I’m glad that you finally solved the problem - when you moved data it inherit a current correct permissions without OWNER-CREATOR and with SYSTEM as an owner and full rights. So this is the same as recursively apply both (those two checkboxes above).

but you’ve certainly knew that if you haven’t run with super user, you’ll get bad exp. with my little usage of linux it is a more predictable system when you know what to do. i’ve just paused for now, after i’ve tried the command that uncover the issues and threats at a clean installment of ubuntu (don’t remember what the command is).
in windows case there is too much unknown parameters where to look or think at in case of serious problems and it is not always clear vision how to fix (docker repeat with sharing of the disks, it is obvious when you know that you should make remove and rerun the marks of shared disks, but when you’ll get it for the first time it goes to forever to find the right way) and the solution not always the same in same cases.

it is not a salvation - I’ve just give up for now and move the riddle in the future.

good advise, thanks!

Hi!
Still got issues with waking up 2nd node, for right now the build looks like this:
Docker 3.1.0 (51484) with wsl2 and ubuntu distr;
The command I’ve used in Power Shell with adm rights:
the settings rolls up via Power Shell

1st:
docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967 -p 127.0.0.1:14002:14002 -e WALLET=“X” -e EMAIL=“Y1” -e ADDRESS=“Z:28967” -e BANDWIDTH=“50TB” -e STORAGE=“11.5TB” --mount type=bind,source=“F:\data\identity\storagenode\”,destination=/app/identity --mount type=bind,source=“F:\data”,destination=/app/config --name storagenode storjlabs/storagenode:latest

works fine.

2nd:
docker run -d --restart unless-stopped --stop-timeout 300 -p 28968:28967 -p 127.0.0.1:14003:14002 -e WALLET=“X” -e EMAIL=“Y1” -e ADDRESS=“Z:28968” -e BANDWIDTH=“50TB” -e STORAGE=“11.5TB” --mount type=bind,source=“E:\data\identity\storagenode3\”,destination=/app/identity --mount type=bind,source=“E:\data”,destination=/app/config --name storagenode3 storjlabs/storagenode:latest

and there is a big rabbit hole - for now I have stuck at this:

The rights for this HDD looks like this:

1st (working node)

2nd (not working node)

changing owner from Administrators to SYSTEM leads to corruption $RECYCLE.BIN and System Volume Information.

After starting the command for 2nd node, the node goes to endless restart with next mentions in logs:

2021-01-28T13:32:40.134Z INFO Operator email {"Address": "Y1"}
2021-01-28T13:32:40.134Z INFO Operator wallet {"Address": "X"}
Error: Error starting master database on storagenode: group:
--- stat config/storage/blobs: no such file or directory
--- stat config/storage/temp: no such file or directory
--- stat config/storage/garbage: no such file or directory
--- stat config/storage/trash: no such file or directory

It is what exactly I get when start with command fo 2nd node mentioned above.

Tried to check creating the test file with Docker, seems goes ok:


Command docker exec -it storagenode3 sh
Leads to error:
Error response from daemon: Container e73c3256d049d429f0d6374da84d1dcfa7afef07a57564360ae44f7c65cb9c96 is restarting, wait until the container is running

Do know how to move further, please help

Meaning that you did not run setup for the second node. Please, do it (but you will need to remove config.yaml first): https://documentation.storj.io/setup/cli/storage-node#setting-up-the-storage-node

Oh, I’ve missed the new chain parameter in node setting.
After caesarean the new node is born.
Thank you, Alexey!

1 Like