Error starting master database on storagenode

Hello. Yesterday tried to start a new node, it started all ok, but after some time it went down and i cannot start it up again :expressionless:
Tried to look here in the forum, but could not find the same problem. By the way initial docker setup also showed some errors, but as the node started, i’ve deleted that error…

Error: Error starting master database on storagenode: database: info opening file “config/storage/info.db” failed: unable to open database file: no such file or directory
storj.io/storj/storagenode/storagenodedb.(*DB).openDatabase:324
storj.io/storj/storagenode/storagenodedb.(*DB).openExistingDatabase:306
storj.io/storj/storagenode/storagenodedb.(*DB).openDatabases:281
storj.io/storj/storagenode/storagenodedb.OpenExisting:248
main.cmdRun:193
storj.io/private/process.cleanup.func1.4:363
storj.io/private/process.cleanup.func1:381
github.com/spf13/cobra.(*Command).execute:852
github.com/spf13/cobra.(*Command).ExecuteC:960
github.com/spf13/cobra.(*Command).Execute:897
storj.io/private/process.ExecWithCustomConfig:88
storj.io/private/process.ExecCustomDebug:70
main.main:474
runtime.main:255

The error suggests that some of the configuration is not correctly setup for docker.

There are quite a few things that need to be changed in the docker run command and if they haven’t been updated the storagenode won’t run. Maybe you missed one of them? Storage Node | Storj Docs

Based on error it should be <identity-dir>, but there might be other values missing as well.

Which operating-system are you using?

it’s ubuntu.

Well i believe that without identity it would not be able to start at all. But yesterday i’ve seen running dashboard, as well there was already about 50Mb of data downloaded over the first hour of run. So it started and was running fine for hour or two.

p.s. I’ve copied both docker scripts (setup+final) from your link :slight_smile:

Oh, sorry, I got <identity-dir> and <storage-dir> args confused. Is the folder you specified for <storage-dir> accessible from Ubuntu? Maybe it got unmounted?

It was the first thing I’ve checked :slight_smile: drive is mounted.

strage…

tried to create a folder, got error as read only drive. Then i’ve unmounted/mounted back and it is writable again :face_with_raised_eyebrow: node is runing fine. for now…

i don’t like it… looks like hdd glitch :face_with_raised_eyebrow:

2 Likes

If there was an error that lead to the drive becoming read only, it was likely logged into kernel message buffer and/or system log. Does dmesg, journalctl or an alternative that you use on this system have any error messages for this drive?