Error starting master database (operation not permitted) after update on QNAP-Nas

which files you mean in detail? i checked all *.db files as you see above. also i checked some samples in the subdirs of config-dir. All are full writeable by owner :confused:

parent directory too?

yes :frowning: it is 700, with matching ownerships

Whoops, sorry Karl, I kind of assumed this was about the QNAP app.

@BrightSilence - no worries. Looks like something else, but you never can be too careful :slight_smile:

@beli Can you provide us with the docker run command you used to start the container? Can you confirm that the /app/config/config.yaml contains the path inside the container you’ve bind mounted?

@user01357 Are you also running on QNAP or is this a different kind of host environment?

Yes - paths are matching - only “change” was upgrade from 1.6.4 to 1.9.5 i think.

docker run -d --restart unless-stopped -p 28967:28967 -p 14002:14002
-e WALLET=“wally”
-e EMAIL=“mailly”
-e ADDRESS=“addressy”
-m 4096M
–mount type=bind,source="/share/Container/STORJ/identity",destination=/app/identity
–mount type=bind,source="/share/Container/STORJ/config",destination=/app/config
–stop-timeout 300
–name storagenode storjlabs/storagenode:latest

I using the docker image on the QNAP device which updating by watchtower.

Exactly the same here, docker image in qnap device + watchtower

I have the same setup and no problems so far. My watchtower updated to 1,9,5 yesterday…

Hello, my QNAP app can’t start after the second day I upgrade to the newest version.

Even I installed the old version still not working.

Here’s the log, thanks.

Hello @qookoo,
Welcome to the forum!

For some reason the container on QNAP requires --privileged option in the docker run command.

Do you have any tutorial to do this?

or will you solve this problem in the future app update?

I’m new to this, even after googling it still feel confused.

Hey @qookoo! That is a great question @utropicmedia-karl might be able to give us more information about how to do this or if it going to be updated in the next release.

Hi qookoo,

What is the firmware version of your qnap?



If i can also answer :wink:

Mine is now, i updated to newest version during debugging

[Firmware Update] Updated system from version to

on 4.4.2 the system was running since 1.june 2020

So, the --priveleged start to be required after firmware upgrade?

No. The storagenode V1.9.5 was not starting with “operation not permitted” with both firmwares.
To debug the situation i upgraded to actual firmware but no change. Still “operation not permitted”.

My QNAP model is TS-231P2.

My system version was, and I update it to but still not work.