# “error”: “untrusted: unable to get signee: trust: rpc: tcp connector failed: rpc: dial tcp: lookup us1.storj.io: operation was canceled

**URL:** <https://forum.storj.io/t/error-untrusted-unable-to-get-signee-trust-rpc-tcp-connector-failed-rpc-dial-tcp-lookup-us1-storj-io-operation-was-canceled/22772>\
**Category:** troubleshooting\
**Tags:** docker, btrfs, на-русском, synology-nas, disqualification\
**Created:** [May 23, 2023, 4:01am UTC](https://forum.storj.io/t/error-untrusted-unable-to-get-signee-trust-rpc-tcp-connector-failed-rpc-dial-tcp-lookup-us1-storj-io-operation-was-canceled/22772 "2023-05-23T04:01:37Z")\
**Posts on this page:** 1\
**Showing post:** 9

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [May 24, 2023, 3:26am UTC](https://forum.storj.io/t/error-untrusted-unable-to-get-signee-trust-rpc-tcp-connector-failed-rpc-dial-tcp-lookup-us1-storj-io-operation-was-canceled/22772/9 "2023-05-24T03:26:42Z")

</div>

> [@shaltay](#):
>
> `11:49:08 Error: unrecoverable error accessing data on the storage file system (path=config/storage/blobs/ukfu6bhbboxilvt7jrwlqk7y2tapb5d2r2tsmj2sjxvw5qaaaaaa/3o/2a2i6cribujsomsow5c45wr4p5rqdtjoti7dyciultzapzjqia.sj1; error=lstat config/storage/blobs/ukfu6bhbboxilvt7jrwlqk7y2tapb5d2r2tsmj2sjxvw5qaaaaaa/3o/2a2i6cribujsomsow5c45wr4p5rqdtjoti7dyciultzapzjqia.sj1: input/output error`

Вам нужно проверить диск на ошибки и исправить их. Возможно identity тоже повреждена.  
Если после исправления ошибок на диске проблема сохранится, тогда продолжим:

Есть хоть одна ошибка `ping satellite failed` но без `ratelimit`? Потому что `ratelimit` это последствие частых попыток регистрации с ошибкой (неправильный внешний адрес например), а не причина.  
Я бы порекомендовал попробовать использовать просто публичный IP. Возможно сателлит не может надёжно ресолвить предоставленный hostname в IP и использует предыдущий из кэша, а он сменился. Или пробует использовать IPv6, а он у вас не настроен на этом хосте или не разрешены порты узла для IPv6 UDP/TCP.

У вас сохранился бэкап этой identity? Если да, сохраните текущую и восстановите из бэкапа, только убедитесь, что она та же самая, например так:

> [@RaspberryPi crash](https://forum.storj.io/t/raspberrypi-crash/22571/5):
>
> ./identity certificate-authority id --ca.cert-path /mnt/storagenode2/identity/ca.cert It will print a NodeID. Then you need to search in your logs, what was the NodeID before. Please also SKIP a SETUP step, it must not be executed again for a worked node, otherwise you can destroy it. no, this token is one-time only and can be used only once to sign any identity, after that it has no use. It also doesn’t contain any info related to your node (even to used email address, it’s just used for …

Если она была не подписана - подпишите новым токеном авторизации и используйте эту версию.  
Если бэкапа нет, попробуйте сделать так:

1. Остановите и удалите контейнер storagenode
2. Сделайте резервную копию папки identity
3. удалите из текущей папки с identity файлы `identity.cert` и `ca.cert`
4. Скопируйте файл вида `identity.1560971067.cert` как `identity.cert`, а файл вида `ca.1560971067.cert` как `ca.cert` (цифры у вас будут свои - это дата в Unix формате, когда вы подписывали identity в первый раз).
5. Подпишите эту identity новым ключом авторизации
6. Проверьте, что NodeID не изменился, таким запросом: [RaspberryPi crash - #5 by Alexey](https://forum.storj.io/t/raspberrypi-crash/22571/5)
7. Если NodeID тот же - стартуйте узел и понаблюдайте за логами.

---

_[View the full topic](https://forum.storj.io/t/error-untrusted-unable-to-get-signee-trust-rpc-tcp-connector-failed-rpc-dial-tcp-lookup-us1-storj-io-operation-was-canceled/22772)._
