Errors running the docker container

I on the third attempt trying to setup my node on ubuntu and I am getting the following errors. The first one is when i run the initial docker command, and the second occurs when i run the second command(logs obtained from protainer):

Running ./storagenode setup --config-dir config --identity-dir identity --metrics.app-suffix=-alpha --metrics.interval=30m --version.server-address=https://version.storj.io --console.address=:14002 --storage.allocated-disk-space=2.0TB
2023-01-05T15:23:52.894Z INFO Anonymized tracing enabled {“Process”: “storagenode”}
Error: open /app/config/config.yaml3369685483: permission denied

— stat config/storage/temp: no such file or directory
— stat config/storage/blobs: no such file or directory
Error: Error starting master database on storagenode: group:
— stat config/storage/trash: no such file or directory
— stat config/storage/garbage: no such file or directory
2023-01-05 15:30:56,997 INFO exited: storagenode (exit status 1; not expected)

It doesn’t have permissions to create a config.yaml file in the path config.
Perhaps you need to provide an absolute path instead, especially if it’s not in docker (otherwise why do you trying to run storagenode setup directly?).
If it’s a docker version, then you need to run it differently: Storage Node - Storj Node Operator Docs