Failed to get storagenode work on CentOS 7.6

Hi all,

I am installing storage node on CentOS 7.6, but unfortunately it doesn’t work, docker continuously restarts,
I uses “docker logs” and get following messages:
2019-12-01T12:29:54.850Z DEBUG process/debug.go:51 debug server listening on 127.0.0.1:44974
2019-12-01T12:29:54.850Z FATAL process/exec_conf.go:288 Unrecoverable error {“error”: “storagenode configuration already exists (/app/config)”}

who can give me a hand? Thanks in advance.

Here comes my docker startup script:
#!/bin/sh

docker run -d --restart unless-stopped
-p 28967:28967
-p 14002:14002
-e WALLET=“0xxxxxxx”
-e EMAIL="xxxxxx@gmail.com"
-e ADDRESS=“xxxxxxxxx.ddns.net:28967
-e BANDWIDTH=“5TB”
-e STORAGE=“1TB”
-v /root/.local/share/storj/identity/storagenode:/app/identity
-v /home/storjdata:/app/config
–name storagenode storjlabs/storagenode

You need to read documentation since the docker run command has long been updated

docker run -d --restart unless-stopped -p 28967:28967 -p 127.0.0.1:14002:14002 -e WALLET=“0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX” -e EMAIL="user@example.com" -e ADDRESS=“domain.ddns.net:28967” -e BANDWIDTH=“20TB” -e STORAGE=“2TB” --mount type=bind,source="",destination=/app/identity --mount type=bind,source="",destination=/app/config --name storagenode storjlabs/storagenode:beta

You are using wrong -v option

You are also missing beta tag

1 Like

Thanks.

I just found the cause: my docker version is too old. After upgrading to 19.03, now it works. But GUI dashboard doesn’t work with 404 error.

How are you accessing GUI dashboard?

Did you edit your docker run command as per above sample?

I hope you did not ignore the comment about not using -v option. It is urgent that you update your docker run command to the correct one, and not wait for your node to crash and be lost because of this.

Thanks for the reminder. The issue has been resolved by upgrading docker.

After adding “beta” version, it works now. Thanks.

1 Like

Once again, please do not ignore the advise about changing -v to --mount now even if just upgrading docker resolved your current issue. You may lose your entire node and data if you have an unexpected outage. Better safe than sorry …

No worry. I have already replaced “-v” option with --mount. Thanks for the reminder.

2 Likes