Graceful Exit error - Can't find any non-exiting satellites

I run Docker in Synology, storagenode ver 1.86.1.
On one of my nodes I did GE for the defunct satellites last month. All worked fine.
Now I tried to start a GE on Saltlake and this is what I got:

docker exec -it storagenode /app/storagenode exit-satellite --config-dir /app/config --identity-dir /app/identity
2023-09-01T21:55:10Z    INFO    Configuration loaded    {"process": "storagenode", "Location": "/app/config/config.yaml"}
2023-09-01T21:55:10Z    INFO    Anonymized tracing enabled      {"process": "storagenode"}
2023-09-01T21:55:10Z    INFO    Identity loaded.        {"process": "storagenode", "Node ID": "....."}
By starting a graceful exit from a satellite, you will no longer receive new uploads from that satellite.
This action can not be undone.
Are you sure you want to continue? [y/n]
Can't find any non-exiting satellites.
Error: rpc: dial tcp connect: connection refused

What seems to be the problem?
Changes from last time: moved from network bridge to network host, to enable TCP_fastopen, and the port numbers. The run command is in my dedicated thread about My Docker Run Commands.

I see that the error reffers to port 7778, but in docker run I set the port to 140xx. Why the GE command dosen’t take into account that change?

For the private API calls like this it uses the server.private-address: address and port.
So, if you run multiple nodes, and uses --network host, you must provide also a private address in the exit command, i.e. if the private server address and port is, then the command will look like:

docker exec -it storagenode /app/storagenode exit-satellite --config-dir /app/config --identity-dir /app/identity  --server.private-address

BTW it’s also required for the CLI dashboard.


So the CLI dashboard should look like this?

docker exec -it storagenode /app/ --server.private-address

Yes, otherwise it will use a default setting.
However you may check, maybe it now reads its configuration (if you changed this parameter in the config.yaml file).

1 Like

I don’t change anything in config. I put everything in docker run.

In this case you need to provide this option to the CLI dashboard without a doubdt.

1 Like