Graceful Exit Guide

6 posts were split to a new topic: Discussion of GE design

2 posts were split to a new topic: Enhance the SNO experience

Hi,
Just an update and a question.
For the following satellites is status is like so.

Domain Name Node ID Percent Complete Successful Completion Receipt
satellite.stefan-benten.de:7777 118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW 0.00% N 0a47304502205070a80c8db691ac877609cf0fd6e496a5026dfe8d5da93cb85fd7e7e8ef4076022100afb21eaac9b14845892006f784936dc79e638fd47c1e4a4a5d39521e7f93d72e1a20004ae89e970e703df42ba4ab1416a3b30b7e1d8e14aa0e558f7ee2680000000022206bbfde33c974001aa97666637c4f3ebaa6db3e5f88e75c8544b215e7000000002a0b088de3d1f40510a8abfc2d
asia-east-1.tardigrade.io:7777 121RTSDpyNZVcEU84Ticf2L1ntiuUimbWgfATz21tuvgk3vzoA6 100.00% Y 0a4630440220067501237395d8a9002422474f3ef753079a04015ce59f1281c08a4fb57c9bd9022078460aa49dc660c1798e43c00756f5b085de1bb059c20d4f9f90fd8a7f8a544b122084a74c2cd43c5ba76535e1f42f5df7c287ed68d33522782f4afabfdb400000001a206bbfde33c974001aa97666637c4f3ebaa6db3e5f88e75c8544b215e700000000220c089ae4a3f50510c296edcd01
us-central-1.tardigrade.io:7777 12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S 100.00% Y 0a47304502207d6fedc025aaf3c4f30a97e9365de0b3584a9a8668e137521494b53615b2fe610221008b0899bec8850c814d0e5c1896d19fad136a9952dd85a5c98557a984b73ab55c1220a28b4f04e10bae85d67f4c6cb82bf8d4c0f0f47a8ea72627524deb6ec00000001a206bbfde33c974001aa97666637c4f3ebaa6db3e5f88e75c8544b215e700000000220b08d3c2a7f50510f0b2a750
europe-west-1.tardigrade.io:7777 12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs 100.00% Y 0a4730450221009a9d434d2ee2db0ac22f76ca7a335d4178f58f62992926c5437b7075138a0d88022079da32c67fa7ab93317cba1c948a756728ea2c8efa9ba775aabbfa73de48fff71220af2c42003efc826ab4361f73f9d890942146fe0ebe806786f8e71908000000001a206bbfde33c974001aa97666637c4f3ebaa6db3e5f88e75c8544b215e700000000220c0883878ef60510caf9d4c302

However, when I rerun the exit-satellite command the following are displayed:

docker exec -it storagenode /app/storagenode exit-satellite --config-dir /app/config --identity-dir /app/identity
2020-05-20T05:38:23.377Z INFO Configuration loaded {“Location”: “/app/config/config.yaml”}
2020-05-20T05:38:23.378Z INFO tracing disabled
2020-05-20T05:38:23.408Z INFO Identity loaded. {“Node ID”: “1pTKKtnkbmWVEYcTZiSD4adEUqSQhveEhrTgUWg5xzTeAshL3W”}
By starting a graceful exit from a satellite, you will no longer receive new uploads from that satellite.
This action can not be undone.
Are you sure you want to continue? [y/n]
:y
Domain Name Node ID Space Used
saltlake.tardigrade.io:7777 1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE 1.1 TB
europe-north-1.tardigrade.io:7777 12rfG3sh9NCWiX3ivPjq2HtdLmbqCrvHVEzJubnzFzosMuawymB 347.7 GB
Please enter a space delimited list of satellite domain names you would like to gracefully exit. Press enter to continue:
saltlake.tardigrade.io:7777 europe-north-1.tardigrade.io:7777

So there are 2 satellites remaining for GE. But after a few minutes the progress of those satellites is not available, somehow they disappear and the exit-status command only shows the satellites GE is already finished. Any hint?

They are newer satellites and your node needs to be of some “age” (6months/15months) to be able to qualify for GE on them.

1 Like

yeah it’s 6 months currently, and will go back to 15 months at some point, and it can be a bit buggy to my understanding, still not a finished feature.

This is a wrong assumption. We have had enough successful GE of nodes.
As you know, usually people post on forum in case of problems, it’s a very rare to have a positive post like

4 Likes


I have started exit. 1-hour passed and still have 0% for all 4 satillies. Other problem i have stared 6 satilliets, but 2 were disappered and if i start exit again i see them in list. Is that ok? But free space look like growing if check the dashboard

you have to reach 6 months on a satellite to be able to GE… atleast 1 of the remaining 2 where added within the last 6 months, so this is most likely the cause for why you cannot GE them remaining.

So if i GE from satellite that hold ammoount of summ, it will pay me, doesn’t matter if i’ll stay with outher satellites?

This is only the case if you are successful at a GE if your node isnt at least 6 months old with each satellite it will not perform a GE and it will tell you that you can’t run it till a certain date.

The satellites have to collect the data on which pieces your node should transfer. This takes a little time. It will then send out tasks for your node to complete in batches.

The satellites you exit will pay out their held back amount independent of satellites you don’t exit. But you won’t get the held back amount from the satellites you can’t yet exit. It’s up to you whether you want to keep them running until you can.

I believe there should be probably docker in the begining or/and some other options?
Tried to GE on of the nodes, but of course get this error:

$ storagenode exit-satellite
storagenode: command not found

T.Y.

Should i stop current running docker container or should i run “exit-satellite” on the running one?

P.S. I’ve made search on this forum, looked at almost all topics about GE as well checked documentation.storj.io, but did not found clear GE examples as for the installation :expressionless:

:slight_smile: thank you. But you’ve pointed in to the same topic, that we are now :smiley:

FYI, if you try to do graceful exit when your node is not eligible yet, you will get no warning and it’ll show 0%. If you restart the node, there will be an error message at start saying you are not eligible, and graceful exit is stopped.

This node is older then 6 months. It joined network on 2019-11.
And it have 100% audit checks with all satellites.
So should be fine?

Strange things happening:

Don’t change the config-dir and identity-dir paths, they point to the mapped paths inside the container, which are the same for everyone.

1 Like

Thank you!!

Thought that this is same story as with the startup command.