I can't download a big file back

Just so I understand this correctly,
the download fails with the described error, then automatically restarts, fails again, and so on?

I have uploaded it only today and no successful download.

Yes, that is exactly what happens.

Ok. I think the retries might be part of filezilla’s implementation.
You say you’ve been testing uploads/downloads for a little while now?
If you have other objects, are you able to download those?

Yes. Normally no issues. I wonder if it could be a matter of size.
The largest file I had so far was around 2 GB and there were no issues with that one as well.

Edit: I have just tried and downloaded a 6 GB file and there were no issues with it.


I was able to reproduce an issue and created a bug for it.


Would you like to link the file so more of us can have a try at downloading it?

I have no idea how I can make this file available for download.
But you can download the original big files from here if you want to test: The digital cinema as potential Tardigrade use case?

It’s simple, but you would be charged for downloads.

uplink share --url sj://dominion/ToS_4k_DCP.zip

It’s the Filezilla test account. I’m not using CLI.
And I cannot remember my encryption password as it is stored in Filezilla.

You can take an API key and encryption phrase from the Site manager:

As I heard the next (maybe alpha?) version of FileZilla should have an ability to create a shareable URL right from the UI, but I have no details yet.

Also, I think the generated URL could be useless, because you likely will not see an error if download file via linkshare.
Maybe you should give an access grant instead. In the last case I would recommend to limit it by time: https://documentation.tardigrade.io/getting-started/sharing-your-first-object/share-a-restricted-access-to-an-object

1 Like

That worked, thanks. Could not believe that it is plain text.

I guess you’re right. But I have created it. Maybe @ACarneiro just needs a source for a big file. Now isn’t the map beautifully blue: http://link.tardigradeshare.io/s/15ERP1SRFKY2obM79Ro3FbbTEMJYoEo7uS2B372tsUf8pvzgeE7v3FFo7R6idGSzVrWCk5zDUJGwzqB2BbSQ5ZmTn5MZkHv4A4Ae3RGeKhssYmDdtqPx7puLRKbreqM3NHaCTWngJ57MzHd7M6PaNFsZ7LAXiGGCHd68bBoNkKzMTCzjnbsyTJFVvJqwhTxnUNSQD5W7eGEf1iCdAo6nwVhJxXymMyKpnhGiTk5Uptfvu5eQNfvFpoWPcBhAbvQrNFxT8haSUAWqtDEFnP1affnhEWks5M8To6vqYBxTaG9oCxbcSLXMjhwAFvnPyhFtE8tzjBr5oDyzYdJpHyoZ4kv3B/dominion/j2c_59b5ad71-013c-4cda-94ab-2064df2c89bb.mxf?wrap=1

@Alexey From what I see only time based limits are possible for the share. But number based would be great to. So to restrict by the numbers of downloads.

Edit: @Alexey: How can I give access for somebody else with Filezilla?

I have no idea.
As I said,

At the moment the link generation is possible only via uplink and Tardigrade S3 Gateway.

I think it’s useless - the restriction is absolute. I.e. - if you limit to 2 downloads, as soon as it would be reached, the link will stop to work forever.

I meant not generate in Filezilla but that some other Filezilla can download the file without me having to pass passwords.

Exactly. This would be great.
@Alexey Look, just one sample use case: Think of a media professional who shares a movie for a festival. For him it would be an additional security step, to limit the number of downloads to prevent unwanted spreading of the files in question. So he would set the limit maybe to 3 and can rest assured that it cannot be downloaded more often than that.

Not with FileZilla
You can share a limited access grant with uplink

$ uplink share --public --not-after +24h sj://dominion/j2c_59b5ad71-013c-4cda-94ab-2064df2c89bb.mxf
Sharing access to satellite 12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs@europe-west-1.tardigrade.io:7777
=========== ACCESS RESTRICTIONS ==========================================================
Download  : Allowed
Upload    : Disallowed
Lists     : Allowed
Deletes   : Disallowed
NotBefore : No restriction
NotAfter  : 2021-01-11 19:41:17
Paths     : sj://dominion/j2c_59b5ad71-013c-4cda-94ab-2064df2c89bb.mxf
Access: 15....

Then give the access grant to someone. They then can import it and use it (not after 24 hours):

uplink import dominion 15...

Then download it via uplink to see an error

uplink --access dominion cp sj://dominion/j2c_59b5ad71-013c-4cda-94ab-2064df2c89bb.mxf .

By the way, your current link is consist of such an access grant and path to the file. But it’s unlimited as far as I can see.

I see. I am not really familiar with uplink. But I’ll check it out.

You can add this suggestion there: DCS feature requests - voting - Storj Community Forum (official)


I think that bug got fixed. Could you please check on your side?

1 Like

You mean the initial bug?
I cannot download anymore as the quota has been reached.
I’ll check it again as soon as I have access to a large file like this again.

The OP bug?
If so, I can try to push one of our ~30GiB 7z archives up and then back down in filezilla tomorrow to test.