# In-memory buffer for uploads

**URL:** <https://forum.storj.io/t/in-memory-buffer-for-uploads/9033>\
**Category:** troubleshooting\
**Tags:** на-русском\
**Created:** [September 8, 2020, 7:06am UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033 "2020-09-08T07:06:58Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![serger001](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/serger001/32/1122_2.png) [@serger001](https://forum.storj.io/u/serger001)\
**Post date:** [September 8, 2020, 7:06am UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033/1 "2020-09-08T07:06:58Z")

</div>

Man, disable “in-memory buffer for uploads” option in config.yaml. In windows this option crush client after 1-5 minutes with error:  
2020-09-08T11:18:20.601+0500 FATAL Unrecoverable error {“error”: “debug: http: Server closed”, “errorVerbose”: “debug: http: Server closed\n\[tstorj.io/private/debug.(\*Server](http://tstorj.io/private/debug.(*Server)).Run.func2:108\n\[tgolang.org/x/sync/errgroup.(\*Group](http://tgolang.org/x/sync/errgroup.(*Group)).Go.func1:57”}

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [September 8, 2020, 7:39am UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033/2 "2020-09-08T07:39:13Z")

</div>

Hello @serger001,  
Welcome to the forum!

This error is happening only on restart and it doesn’t crash the client. If you want to avoid it, you can specify the debug port instead of `:0`. But it does not prevent storagenode from working.

---

<div class="post-metadata">

**Author:** ![serger001](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/serger001/32/1122_2.png) [@serger001](https://forum.storj.io/u/serger001)\
**Post date:** [September 8, 2020, 6:10pm UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033/3 "2020-09-08T18:10:30Z")

</div>

Доброго дня) но ведь при этом останавливается сервис. Разве это не останавливает ноду?

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [September 8, 2020, 6:35pm UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033/4 "2020-09-08T18:35:40Z")

</div>

Vice versa. This error is happen after request to stop the service but not the reason of that.

> **На русском**
>
> Наоборот. При остановке сервиса возникает эта ошибка. Она не является причиной остановки.

---

<div class="post-metadata">

**Author:** ![serger001](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/serger001/32/1122_2.png) [@serger001](https://forum.storj.io/u/serger001)\
**Post date:** [September 8, 2020, 6:45pm UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033/5 "2020-09-08T18:45:47Z")

</div>

Странно. Я поставил версию 1.11.1. Вчера вечером, всю ночь нормально работала. Сегодня решил посмотреть что там интересного в конфиге есть. Ничего интересного, кроме одного единственного параметра не нашел. Поменял его, перезапустил ноду. Минут через 10 отвалился веб интерфейс, при этом сервис тоже встал! Я руками запустил сервис, веб поднялся. Минут 10 прошло, снова упал сервис и веб. Я закомментил эту строчку - работает уже часов 10, проблем нет. Явно где-то есть проблема в этой опции в виндовом клиенте.

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [September 8, 2020, 6:54pm UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033/6 "2020-09-08T18:54:45Z")

</div>

> [@Cant get new node running](https://forum.storj.io/t/cant-get-new-node-running/7556/14):
>
> in-memory buffer for uploads

Зависит от того, насколько сильно вы поменяли значение этого параметра. А главное - зачем?  
Ни один параметр в конфиге не увеличит загрузку на ваш узел. Использование зависит от клиентов, а не от параметров в конфиге или аппаратного обеспечения.

---

<div class="post-metadata">

**Author:** ![serger001](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/serger001/32/1122_2.png) [@serger001](https://forum.storj.io/u/serger001)\
**Post date:** [September 8, 2020, 7:03pm UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033/7 "2020-09-08T19:03:35Z")

</div>

Честно-увидел знакомые буквы с буфером 🙂 к дефолтным параметрам добавил нолик всего.

---

<div class="post-metadata">

**Author:** ![Alexey](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/alexey/32/41_2.png) [@Alexey](https://forum.storj.io/u/Alexey)\
**Post date:** [September 8, 2020, 7:25pm UTC](https://forum.storj.io/t/in-memory-buffer-for-uploads/9033/8 "2020-09-08T19:25:02Z")

</div>

Он применяется к каждому кусочку. То есть вместо 128кб вы настроили 1280кб. Для всех тысяч кусочков. Память должна заканчиваться очень быстро. Неудивительно, что Windows выкидывала жадный до памяти процесс 🙂
