Last contact: 17699707h 56m ago

After a restart of my node I get this thing here:


Did an update to latest version, same thing…

Node running on Windows 10

Also port seems to not be open, but it is set in router… sometimes its open, sometimes its closed…

Any ideas?

Thank you!

Firewall blocking connection?

The last contact value suggests that there is/was a problem with your local date/time.

1 Like

Please, go through this checklist:

You have externally checked that your port is still open?

i’m having the same problem.
using no-ip’s port poker. it says connection timed out. what do i do

Have you tried refreshing the page with Ctrl+F5? Maybe the problem is just with the dashboard itself.

1 Like

No-IP will not give you a “white” public IP, if your ISP give you a “gray” private IP.

Please, compare the WAN IP on the main page of your router with IP there: , they should match.
If they do not match, you have a three options:

  • Switch the ISP to the one with a public IPs;
  • Talk with your current ISP and ask how you can obtain a public IPv4, it could be dynamic, but must be a public (i.e. WAN IP match the public IP);
  • Use VPN services with port forwarding option like PIA,, ngrok, PureVPN, etc.

If your WAN IP is match to public IP from yougetsignal, then check your DDNS hostname from No-IP:

nslookup your.ddns.hostname

It should return the same public IP as your WAN IP and IP from the yougetsignal. If not - then make sure that your DUC application is running and updated the DDNS hostname with a new public IP, or configure your router in the DDNS section to do it for you. You should use only one method - either DUC or router, do not run both.

9 posts were split to a new topic: I can see that node flick in rrestarting and connected

Possible causes:

  • your router is not assigning same private ip to your pc after reboot
  • your public ip has changed and now you have a diferent public ip than the one you used during first setup
  • your windows 10 updated and changed firewall rules (sometimes windows changes from private network rules to public network, and firewall is more strict)
  • or maybe the update changed configuration values in your Node config.yaml file

in your storage node folder, open with notepad the file: config.yaml search for lines:

  1. contact.external-address: xx.xx.xx.xx:28967 <- here is your public INETERNET ip and port
  2. server.address: yy.yy.yy.yy:28967 <- here is your private LAN ip and port

This file is usually locate in “C:\Program Files\Storj\Storage Node”
Atention!! Dont change anything in this file, just see if all values are correct with what you configured in your router, and in services like No-Ip
Instead of Windows Notepad, better use Notepad++, it has more features, and editing files is easier.

If you give us more info about your configuration, maybe is possible to point you better.

thank you for your replies, will check back in later to let you know what worked!


Just powered on the node after 2 days and everything is working now…weird…but I get 65h uptime…weird again:))

Anyways, thanks you for your replies once again… Cheers!

1 Like

Perhaps your clock was out of sync

1 Like