Last contact 19 hours ago or OFFLINE on Windows/MacOS

node ID: 12BSpmDm42Ao6w1PB7SWbDBXaafYHfrmvGcwpjEeATTGg4smCYn

Nothing changed.

I this is on a windows system, try restarting docker from the task tray.

It’s fixed. Thanks for advice. Should it be reported to the technical team?
Does it mean that the node was Offline for 19hours and not trusted any more?

No need to report this, it is a known issue with docker for windows. Currently nodes will not be disqualified for downtime, although your reputation will take a hit and will take a bit of time to recover. This may result in less traffic in the short term until your rep has recovered.


Hi guys/girls/etc,
I got an email to upgrade my storagenode. I already had the Watchtower auto update setup, but wanted to be sure. So I stopped the storagenode, ran the update manually, and started. Now, when I go to my dashboard it tells me that my last contact is OFFLINE, and my node version hasn’t changed to the best of my knowledge (honestly I didn’t think to check it before I updated). See below screenshot:

Any ideas of what i’m doing wrong? Pretty sure that if i’m offline, my reputation is by now destroyed despite my best efforts :frowning:

Thanks in advance for the help, and thanks for letting me be part of it.

edit: my uptime is low because I took that screenshot right after I restarted the node. After 3 hours, no change.
edit 2: I found this error in my logs, if that helps anyone. Hopefully I’ve remembered to include everything this time.

2019-07-15T04:11:07.758923900Z 2019-07-15T04:11:07.758Z ERROR vouchers Error requesting voucher {“satellite”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “error”: “voucher: unable to find satellite on the network: node not found”, “errorVerbose”: "voucher: unable to find satellite on the network: node not found

I can’t post links as a new member and couldn’t work out how to remove hyperlinks, and I can only upload 1 pic at a time so that’s why it’s a bit blurry (copy of a copy). Apologies in advance, have to work with what I can do…


Hello @Darthvander83,
Welcome to the forum!

Please, restart the Docker from the Docker desktop application.

Thank you so much, that fixed the issue. I probably should have tried the “turn it off and on again” trick first. Is there any way to confirm what my reputation is now, or will I just have to re-earn it?

There is no such service available at the moment, the SNOboard in the development.
You can see a roadmap here:

2 posts were merged into an existing topic: My Node is OFFLINE for 2 hours

Hi there I am having the same issue with 0.16.1 on my node not connecting. Last contact OFFLINE. Anything I do won’t change it, port forwarding is on and nothing else has changed since this update, the only new thing is docker desktop updates today. I don’t know if this started before that update or after but since 0.16.1 I’ve had issues connecting and even received an email from Shawn saying my node was offline.

Not sure how else to get this working… any help is appreciated

Hey @paulquisha welcome to the forum!

Are you running it on windows? If so, try a clean restart including the OS.

If that doesn’t work, try adding a new rule in windows defender:

Windows Defender Firewall->Advanced Setting->Inbound Rule->New Rule->Port

Should look something like this:

Hope that helps! :sunglasses:


Thanks so much I had to add the rule to the windows defender firewall even tho the port was open in the router. Thanks so much, easy fix!

No problem, a lot of windows users have noticed that issue after the docker update, so you’re not alone. Glad it worked!

Thanks, that helps! Now all works good!

Thanks @faga for joining to our forum and glad that @Dylan reply helped you out.

I have a similar problem after manual update.

Node is offline, and I have checked the following:

  • node version v0.20.1
  • Port opened on router and checked via
  • Firewall rule enabled for port 28967
  • Checked docker exec storagenode ls /app/identity
    ** ca.1557690217.cert
    ** identity.1557690217.cert
  • restarted windows
  • restarted docker

Hey @samuil4 welcome!

What is your docker run command?

Also we just released v0.21.1

Please, run a Powershell with elevated rights and execute:

New-NetFirewallRule -DisplayName "Storj v3" -Direction Inbound -Protocol TCP -LocalPort 28967 -Action allow

Please, show the output of the command:

1 Like

I have finally decided to move this node to a single isp and I have followed the instructions and both dash boards report the node offline and the port has been forwarded in the router and firewall rules have been change < docker run -d --restart unless-stopped -p 48545:28967 -p -e WALLET=“x” -e ADDRESS=“” -e BANDWIDTH=“20TB” -e STORAGE=“4.5TB” --mount type=bind,source=“C:\Users\sorry\AppData\Roaming\Storj\Identity\storagenode”,destination=/app/identity --mount type=bind,source=“D:\storagenode\”,destination=/app/config --name storagenode storjlabs/storagenode:beta this is my docker run cmd with some crude editing hel, here is something odd neighborhood keeps growing

Please run a Powershell with elevated rights and execute:

New-NetFirewallRule -DisplayName "Storj v3 2" -Direction Inbound -Protocol TCP -LocalPort 48545 -Action allow