Less storage used than assigned

Hi all,
I run my node under Linux. I assigned 950GB for the storage.
But now the Node shows that it is full but only used 834GB.
Is this normale? In the trash is only 9GB and under garbage is nothing (4k).

It put some buffer space usualy

Could you please show your dashboard and result of the command:

df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            3.8G     0  3.8G   0% /dev
tmpfs           778M  3.0M  775M   1% /run
/dev/sdb2       1.4T  846G  459G  65% /
tmpfs           3.8G     0  3.8G   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           3.8G     0  3.8G   0% /sys/fs/cgroup
/dev/sdb1       511M  7.6M  504M   2% /boot/efi
/dev/loop5       55M   55M     0 100% /snap/lxd/12317
tmpfs           778M     0  778M   0% /run/user/1000
/dev/loop3       55M   55M     0 100% /snap/lxd/12631
/dev/loop1       90M   90M     0 100% /snap/core/8213
/dev/loop2       90M   90M     0 100% /snap/core/8268
overlay         1.4T  846G  459G  65% /var/lib/docker/overlay2/ad80e708c9e5ebb5f45784ca80c4a8efd9bc6bc6838566c20b7c0c48aefc521f/merged

Please, show the CLI dashboard or result of this command:

docker inspect storagenode -f "{{ .Config.Env }}" | grep -Po "STORAGE=.*? "

This is the output from the command.


CLI Dashboard

Last Contact ONLINE
Uptime 397h45m5s

               Available       Used     Egress     Ingress
 Bandwidth       40.0 TB     6.0 GB     5.9 GB     89.0 MB (since Jan 1)
      Disk       -9.7 MB     0.9 TB

Could part of the problem be because your system displays sizes in GiB? 834GiB roughly equals 896GB (which still doesn’t match your assigned 950GB though).

Note: I believe you can use the international unit by using “-H” instead of -h when using df, so all your values (system & storage node) are displayed using the same scale.

Hi, thats funny…now the data is this:

> root@freenas:~# df -H
> Filesystem      Size  Used Avail Use% Mounted on
> udev            4.1G     0  4.1G   0% /dev
> tmpfs           815M  3.1M  812M   1% /run
> /dev/sdb2       1.5T  908G  493G  65% /
> tmpfs           4.1G     0  4.1G   0% /dev/shm
> tmpfs           5.3M     0  5.3M   0% /run/lock
> tmpfs           4.1G     0  4.1G   0% /sys/fs/cgroup
> /dev/sdb1       536M  8.0M  528M   2% /boot/efi
> /dev/loop5       58M   58M     0 100% /snap/lxd/12317
> tmpfs           815M     0  815M   0% /run/user/1000
> /dev/loop3       58M   58M     0 100% /snap/lxd/12631
> /dev/loop1       94M   94M     0 100% /snap/core/8213
> /dev/loop2       94M   94M     0 100% /snap/core/8268
> overlay         1.5T  908G  493G  65% /var/lib/docker/overlay2/ad80e708c9e5ebb5f45784ca80c4a8efd9bc6bc6838566c20b7c0c48a            efc521f/merged

Have you problems with a database in the past?

No, no problems since start. The only thing i change was that i assigned more storage in the docker command after an software update.

Try to restart the node and look what happened

ok, i restarted it (i had to do an update to 0.28.4 now) it is running and connected but it shows the same data as before. now i am in the negative.

now the dashboard shows 10GB free space and the networktraffic start up/downloading again…i wait and see what happens