MACOS docker run --rm -e SETUP="true" error

Team Storj,

I need some help setup up the storagenode. I have followed all the steps:

  1. Identity Generation
  2. port forwarding (including no-ip setup, DUC setup)
  3. docker install for macOS (installed version
  4. docker pull storjlabs/storagenode:latest

Since I installed docker version I had to modify the docker run setup command to include -v instead of --mount:

docker run --rm -e SETUP=“true”
-v type=bind,source="/volumes/MacHD/Users/media2/Library/‘Application Support’/Storj/Identity/storagenode",destination=/app/identity
-v type=bind,source="/volumes/MacHD-Data/storj-vol",destination=/app/config
–name storagenode storjlabs/storagenode:latest

However, I am getting an error when I try to run the above command:

Error: file or directory not found error: open identity/identity.cert: no such file or directory

The path stated above does contain the identity.cert file:

% pwd
/volumes/MacHD/Users/media2/Library/Application Support/Storj/Identity/storagenode
% ls
ca.1616912337.cert ca.key identity.cert
ca.cert identity.1616912337.cert identity.key

Any help would be appreciated.


Are those single quotes around Application Support in your command? Because that might be the issue. Since the whole string is quoted I don’t think those would be necessary.

Thanks for the response. I removed the single quotes and I still get the same error.

DO NOT use -v and follow the documentation

docker run --rm -e SETUP="true" \
    --mount type=bind,source="/volumes/MacHD/Users/media2/Library/Application Support/Storj/Identity/storagenode",destination=/app/identity \
    --mount type=bind,source="/volumes/MacHD-Data/storj-vol",destination=/app/config \
    --name storagenode storjlabs/storagenode:latest

This :arrow_up: should be your command.


when using the --mount command i get the following error:

docker: Error response from daemon: invalid mount config for type “bind”: invalid mount path: ‘“Volumes/HD1TB/Users/storj/identity”’ mount path must be absolute.

i moved the directories around after a reinstall.

thanks in advanced for any and all help.


Show your new command and put the command between 3 backticks ```

New Command that i am using that give me the “mount path must be absolute” error

docker run --rm -e SETUP="true" \
--mount type=bind,source=“/Volumes/HD1TB/Users/storj/identity”,destination=/app/identity \
--mount type=bind,source=“/Volumes/HD1TB/Users/storj/storagenode”,destination=/app/config \
--name storagenode storjlabs/storagenode:latest

Here is the error message:
storj:~ storj$ docker run --rm -e SETUP=“true” \

–mount type=bind,source=“/Volumes/HD1TB/Users/storj/identity”,destination=/app/identity \

–mount type=bind,source=“/Volumes/HD1TB/Users/storj/storagenode”,destination=/app/config \

–name storagenode storjlabs/storagenode:latest

docker: Error response from daemon: invalid mount config for type “bind”: invalid mount path: ‘“/Volumes/HD1TB/Users/storj/identity”’ mount path must be absolute.

See ‘docker run --help’.


Hello @GasPiston ,
Welcome to the forum!

Seems you have used a word processor to prepare your command and it’s replaced straight quotes to the curly ones:


Please, replace them to a straight ones: " in the plain text editor, such as nano in the terminal (Notes will not work).