My port closes from time to time

So the port to my node seems to close itself.
I dont know if my modem/router tries to give another ip to my server or what happens.

After this night when uptimerobot reported port closed for almost 4 hours I gave the server a static ip in network settings.

I have no idea if this will do the trick but ill see.
Usually when this happens (only at night or when im at work) its only for some seconds up to one minute.

My modem is a Technicolor TG799VAC XTREAM provided from my ISP.

Evert time its rebooted it handled out new ip’s so that has given me alot of problem in the past.

But when the port has been closed, and when I check the server later on the ip is the same so i dont think that is the problem.

Is there a way to find out why the port open and closes itself?

bridge your isp’s gateway and use your own router and set port forward from there just saying

Ok ill try that if this config dont help.
Thanks for tip.

I have only 1 router and its placed in another part of my house to get better wifi but if it going to continue ill change place on it or better of just buy a new one

Do you use WiFi for the node too?

No the node is cabled

Can you view the log of the cable modem at all? It might indicate that there was some type of signalling error. I monitor four separate nodes currently and one of mine drops for 1 minute here and there and it’s the cable modem re-initializing for whatever reason overnight. It doesn’t do it every night but…I’d check the logs if you can.

I dont know if i can but ill give it a go.

I didnt find any log but ill search the net later to see of there is a way

You may find this helpful if you are like me:

I read your post earlier but its not the same but thanks for wanting to help.
Still trying to figure out how to see the logs on my modem/router.

in my xfinity router/gateway they are in the “Troubleshoot” section of the gateway admin tool
I would also recommend using as a notifier to get alerts when the port closes.

I have been to every tab in my gateway but no luck at all finding logs. Seems like I have to hack the gateway to get to the log tab and that feels like wrong way to see logs.
Thats how i know that the port went dont🙂.
Uptimerobot works like a charm.

The port hasnt closed yet after I changed network to static ip in the server

So been a few days now and port Still open after 105 hours. Looks like giving a static ip om the host server did the trick. Ill report back of it fails on me again

Oh you hadn’t assigned a static or “reserved” IP on the router? I’d always recommend that, I usually use reservations so it never hands out that address, except to that host in DHCP.

The gateway have a static ip to the computer, well its via DHCP, but now i have set that ip on the computer to so both have that ip in their setting and it looks like this did the trick

Ok I accidently found out what was wrong.
So dont judge me to much, i have never used VM’s before and never had more than one port on a NIC before.
So here we go,
Linux use port 1 and also docker ofcourse.
Installed a VM to use with my home entertainment as a nas.
I thought for myself, hey I can use port 2 for the VM, and it actually worked good for a some time.
But my gateway didnt like this. It didnt know what port to send what to since i never gave port 2 an ip.
I happened to se this while logged into the gateway trying to solve this issue and saw that the port forward for storj jumped between the ip and 2 Mac adresses

Now the setup is everything going thru NIC’s port 1 and it works great. Port has been open for days now.

So mystery solved😄.

1 Like