New node; Lots of problems. Please help <3

Hi folks,

I have a new node I installed with a 20 TB Enterprise HDD plugged into a windows 10 pro Mini PC with 8 GB Ram and plugged in with ethernet to my spectrum router.

Earlier I had to move some of my office equipment around and the drive came unplugged from the adapter. I’ve fixed and restarted the drive.

-Now I can’t start the storagenode service and I get an error message that the info.db file cant be found on my USBHDD.
-Also I dont think DUC is working properly because it isn’t starting when I start windows.

  • Is there any way I could ask someone to help me figure out my correct IP for a network behind a NAT I cant for the life of me seem to figure this out.

Here is the last 30 lines from my log if its helpful:

(*service).Execute.func1:61\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:75"}
2022-11-26T03:30:21.116-0500 INFO Configuration loaded {“Location”: “C:\Program Files\Storj\Storage Node\config.yaml”}
2022-11-26T03:30:21.116-0500 INFO Anonymized tracing enabled
2022-11-26T03:30:21.116-0500 INFO Operator email {“Address”: “amacko@massdynamicoutreach.org”}
2022-11-26T03:30:21.116-0500 INFO Operator wallet {“Address”: “0xEf3e7bCf1304e2A1ACffD8066A79582AeFe7b264”}
2022-11-26T03:30:21.116-0500 FATAL Unrecoverable error {“error”: “Error starting master database on storagenode: database: info opening file "E:\\info.db" failed: unable to open database file: The system cannot find the file specified.\n\tstorj.io/storj/storagenode/storagenodedb.(*DB).openDatabase:324\n\tstorj.io/storj/storagenode/storagenodedb.(*DB).openExistingDatabase:306\n\tstorj.io/storj/storagenode/storagenodedb.(*DB).openDatabases:281\n\tstorj.io/storj/storagenode/storagenodedb.OpenExisting:248\n\tmain.cmdRun:193\n\tstorj.io/private/process.cleanup.func1.4:377\n\tstorj.io/private/process.cleanup.func1:395\n\tgithub.com/spf13/cobra.(*Command).execute:852\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:960\n\tgithub.com/spf13/cobra.(*Command).Execute:897\n\tstorj.io/private/process.ExecWithCustomConfigAndLogger:92\n\tstorj.io/private/process.ExecWithCustomConfig:74\n\tstorj.io/private/process.Exec:64\n\tmain.(*service).Execute.func1:61\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:75”, “errorVerbose”: “Error starting master database on storagenode: database: info opening file "E:\\info.db" failed: unable to open database file: The system cannot find the file specified.\n\tstorj.io/storj/storagenode/storagenodedb.(*DB).openDatabase:324\n\tstorj.io/storj/storagenode/storagenodedb.(*DB).openExistingDatabase:306\n\tstorj.io/storj/storagenode/storagenodedb.(*DB).openDatabases:281\n\tstorj.io/storj/storagenode/storagenodedb.OpenExisting:248\n\tmain.cmdRun:193\n\tstorj.io/private/process.cleanup.func1.4:377\n\tstorj.io/private/process.cleanup.func1:395\n\tgithub.com/spf13/cobra.(*Command).execute:852\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:960\n\tgithub.com/spf13/cobra.(*Command).Execute:897\n\tstorj.io/private/process.ExecWithCustomConfigAndLogger:92\n\tstorj.io/private/process.ExecWithCustomConfig:74\n\tstorj.io/private/process.Exec:64\n\tmain.(*service).Execute.func1:61\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:75\n\tmain.cmdRun:195\n\tstorj.io/private/process.cleanup.func1.4:377\n\tstorj.io/private/process.cleanup.func1:395\n\tgithub.com/spf13/cobra.(*Command).execute:852\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:960\n\tgithub.com/spf13/cobra.(*Command).Execute:897\n\tstorj.io/private/process.ExecWithCustomConfigAndLogger:92\n\tstorj.io/private/process.ExecWithCustomConfig:74\n\tstorj.io/private/process.Exec:64\n\tmain.(*service).Execute.func1:61\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:75”}

You may recreate it:

However, please make sure that it’s a correct data location (you do not have a duplicate of blobs folder somewhere else).
You may figure out your gateway this way: Step 3. Setup Port Forwarding - Storj Node Operator Docs
If you are in doubt, please post result of the command:

ipconfig

Please place result between two new lines with three backticks, like this:

```
here results
```

It will only start after login to your session, so it’s better to configure updater for NoIP on your router (it’s usually under DDNS section).