New Storagenode register does not work (no invite email)

After figuring out that I have to switch of piholes to start registering - I don’t get any invite mail as last step of the process. Now wating 24h+. Any issue there or what could be the reason not to get an email?

Note: I have already one node running and I want to add a second one (different internet provider and IP…).

thx in advance

Ive never had any issues with getting the email, maybe try another email to see?

Welcome to the forum @endurance!

Which browser did you use ?

User FF as well as chrome - and two different mail adresses as well.

as last step I get

Check Your Email

Your auth token should arrive shortly. Head over to our docs to get started setting up your Node.

but the mail does not arrive

Use ONLY Chrome with NO EXTENSIONS (and of course, no pi hole in your network).

Alternatively, try Edge. It usually only takes some minutes to receive the token.

OK changed to a fresh new installed machine with naked chrome on it -> worked THX

1 Like


I really hope storj does something about that. Nothing short of fresh chrome install in a fresh vm worked for me.

1 Like

The SNO growth team is currently reworking the node signup flow. Please stay tuned.


On 07-07-2019 I finally received the email with my token, try to mount my node but I could not due to total space issues, now I am able to mount a new node but when trying to enter the token the following error appears:
Error: certificates peer error: authorization already claimed: 1RArbx …
Obviously I do not have the data of the first node and I have already requested a new token but it still has not reached me (and I do not know if I can request a new token with the same email)
: S

you have to request a new token with the same address. it should be quick. is it days since you requested it?

about 3 or 4 days ago

For me it reach max in 30 min

Hello @yikoru,
Welcome to the forum!