No data in dashboard after migrating to new computer

Deleted, after restart a new one is in place but the same thing here…

Please show the output of this command:

docker exec -it storagenode ls -l /app/config
docker exec -it storagenode du -hd1 /app/config

nas@nas:~$ sudo docker exec -it storagenode ls -l /app/config
total 128
drwxr-xr-x 4 root root 4096 Aug 18 16:36 backup
-rw------- 1 root root 5783 Aug 18 21:52 config.yaml
-rw------- 1 root root 131072 Aug 19 05:09 kademlia
drwx------ 2 root root 4096 Aug 18 16:36 lost+found
-rw------- 1 root root 32768 Aug 18 21:52 revocations.db
drwx------ 5 root root 4096 Aug 18 21:52 storage

nas@nas:~$ sudo docker exec -it storagenode du -hd1 /app/config
204.6G /app/config/storage
22.1M /app/config/backup
4.0K /app/config/lost+found
204.6G /app/config

I think I’ve found the problem.

The previous storage folder is 290G large, after copying it over to the new computer is is just 204G.

I don’t know if this explains why the dashboard shows just the new uploaded files but it would explain why I have just in some cases the error of missing files displayed inside the log.

1 Like

i did copy all the files again by using the command rsync… instead of cp… and now the dashboard is showing all the previous data.

problem is solved.

now the node is not vetted anymore but i guess that i have to wait just a bit of time to be vetted again.

Thanks for the support! :+1:

Your node is paused at least on one satellite.
Please, send your NodeID, full docker run command and the story to the support@storj.io
You can give a link to the current thread.

Good morning,

Thank for the information. Mail is out!

Have a similar issue:

After migrating of the Server the Dashboard shows no more Bandwidth usage.
All other Informations will be updated correctly.

Also the the audit / successrate.sh shows weired output:
audits_satellites.sh with no Satellite information:

successrate.sh:
Before first audit:

After first audit:

Migration was did with rsync -rtuvP and i don’t receive any Error messages in Log.
Node works still fine.

I just renamed the node.log after the Server was migrated and before
the new was started so that i can get a new one for the new Server.

Any ideas?

Please, clear the cache and cookies, then refresh the page by Ctrl-F5

Thank’s for your response Alex, but i did that already…
Tested the Dashboard on multiple Machines with different Browsers as well.

I also stopped and removed the Node, after restart still the same Issue.

Then you have not synced the last changes after you stopped and removed the node on the old server and you probably got corrupted or missed one of the databases.

Sure?

I don’t see Errors like Databese corrupted.
Any chance to get it back? I saved the “old” Node on Backupserver but the new Node is
already running for 3 Days without Errors in Log.

Will the Dashboard reset automatically next Moth?
Otherwise, I could just wait?

The graph on dashboard is built from the local databases

It should

1 Like

So it will create a new Database for December right?
could work

I’m not sure would it create a bandwidth database, if it doesn’t exist.
Please, show content of your storage folder

Here the content:

total 181320

-rwxrwxrwx 1 root root 1515520 Nov 20 14:30 bandwidth.db

-rwxrwxrwx 1 root root 32768 Nov 20 14:45 bandwidth.db-shm

-rwxrwxrwx 1 root root 4177712 Nov 20 14:45 bandwidth.db-wal

drwxrwxrwx 6 root root 4096 Okt 10 00:42 blobs

-rwxrwxrwx 1 root root 36933370 Sep 30 21:41 dump_all_notrans.sql

-rwxrwxrwx 1 root root 36933416 Sep 30 21:41 dump_all.sql

drwxrwxrwx 2 root root 4096 Nov 20 14:45 garbage

-rwxrwxrwx 1 root root 8192 Okt 3 22:07 info.db

-rwxrwxrwx 1 root root 20115456 Sep 30 21:40 info.db.bak

-rwxrwxrwx 1 root root 32768 Nov 18 17:43 info.db-shm

-rwxrwxrwx 1 root root 0 Nov 18 17:43 info.db-wal

-rwxrwxrwx 1 root root 58331136 Nov 20 14:24 orders.db

-rwxrwxrwx 1 root root 32768 Nov 20 14:45 orders.db-shm

-rwxrwxrwx 1 root root 4519672 Nov 20 14:45 orders.db-wal

-rwxrwxrwx 1 root root 36864 Nov 7 20:23 piece_expiration.db

-rwxrwxrwx 1 root root 32768 Nov 18 17:43 piece_expiration.db-shm

-rwxrwxrwx 1 root root 0 Nov 18 17:43 piece_expiration.db-wal

-rwxrwxrwx 1 root root 16384 Okt 3 22:07 pieceinfo.db

-rwxrwxrwx 1 root root 32768 Nov 18 17:43 pieceinfo.db-shm

-rwxrwxrwx 1 root root 0 Nov 18 17:43 pieceinfo.db-wal

-rwxrwxrwx 1 root root 12288 Nov 18 17:42 piece_spaced_used.db

-rwxrwxrwx 1 root root 32768 Nov 20 14:43 piece_spaced_used.db-shm

-rwxrwxrwx 1 root root 601552 Nov 20 14:43 piece_spaced_used.db-wal

-rwxrwxrwx 1 root root 12288 Nov 18 17:42 reputation.db

-rwxrwxrwx 1 root root 32768 Nov 20 13:47 reputation.db-shm

-rwxrwxrwx 1 root root 395552 Nov 20 13:47 reputation.db-wal

-rwxrwxrwx 1 root root 32768 Okt 5 14:16 satellites.db

-rwxrwxrwx 1 root root 32768 Nov 18 17:43 satellites.db-shm

-rwxrwxrwx 1 root root 0 Nov 18 17:43 satellites.db-wal

-rwxrwxrwx 1 root root 65536 Nov 18 17:42 storage_usage.db

-rwxrwxrwx 1 root root 32768 Nov 20 07:04 storage_usage.db-shm

-rwxrwxrwx 1 root root 280192 Nov 20 05:44 storage_usage.db-wal

drwxrwxrwx 2 root root 4096 Nov 20 14:45 temp

-rwxrwxrwx 1 root root 17154048 Nov 20 14:43 used_serial.db

-rwxrwxrwx 1 root root 32768 Nov 20 14:45 used_serial.db-shm

-rwxrwxrwx 1 root root 4161232 Nov 20 14:45 used_serial.db-wal

I also checked the Dashboard, there is one day missing in the "Disk space used graph.
May the information in bandwidth.db are incomlplete?

Maybe, but it is could be if you didn’t rsynced the source and destination with a --delete parameter after you stopped your node.
This is important step, because you could have a *-wal files (journals of sqlite DBs) synced but not deleted when the node has been stopped. And when you run it on the new system, the sqlite engine is applied the journal and some records are now missed because they could be rolled back.

Bad news :confused:

So the missed records damaged my Dashboard database for Nov cause i didn’t run the --delete option. I could live with that if the Dashboard comes back next month.

Or do you think the Database is definitely corrupted?
Are there any other operations who could be affected due to this issue?

Thanks for your help :wink:

1 Like

Earnings calculator could be affected too

It works, new month new dashboard.

1 Like