# Node DQ on satellite - upload rejected, too many requests

**URL:** <https://forum.storj.io/t/node-dq-on-satellite-upload-rejected-too-many-requests/7474>\
**Category:** troubleshooting\
**Tags:** docker, disqualification, windows\
**Created:** [June 10, 2020, 10:03pm UTC](https://forum.storj.io/t/node-dq-on-satellite-upload-rejected-too-many-requests/7474 "2020-06-10T22:03:55Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![SGC](https://storj.bcdn.literatehosting.com/user_avatar/forum.storj.io/sgc/32/1132_2.png) [@SGC](https://forum.storj.io/u/SGC)\
**Post date:** [June 10, 2020, 10:39pm UTC](https://forum.storj.io/t/node-dq-on-satellite-upload-rejected-too-many-requests/7474/2 "2020-06-10T22:39:55Z")

</div>

upload rejected, too many requests  
happens when request exceed the number set in config.yaml.

> [@Should I change max-concurrent-requests? \>\> Note: The implementation has changed. You shouldn't use this setting any longer. Leave it commented out](https://forum.storj.io/t/should-i-change-max-concurrent-requests-note-the-implementation-has-changed-you-shouldnt-use-this-setting-any-longer-leave-it-commented-out/845/1):
>
> There is not one answer for everyone. If you have low powered hardware, you probably shouldn’t. In worst cases you might want to lower it. But if your hardware is fast and your connection is as well, it could be beneficial to raise this number.
> 
> **How do I change the setting?**
> 
> ```auto
> # Maximum number of simultaneous transfers
> storage2.max-concurrent-requests: 7
> 
> ```
> 
> Add these lines at the end of the config.yaml and play with the number a bit. You have to stop the node, make the change, then start the node again.

limiting max concurrent shouldn’t make the node unresponsive nor get it DQ  
you might have some sort of other issue with the node…  
but you could try to increase the max concurrent or just set it to 0 for infinite

---

_[View the full topic](https://forum.storj.io/t/node-dq-on-satellite-upload-rejected-too-many-requests/7474)._
