Node offline after update to v0.22.1

I check my node every few hours and it was running before the update, now after the update it is showing offline in the dashboard. I did not check over the weekend until this morning due to being away. I have confirmed my port forward is working and that my certs are still the same with no changes. The firewall rule allows port 28967 inbound on the docker windows host. I have restarted the host multiple times and removed and then re-created the container multiple times too. I read in the forum that node checks are done once an hour now so i left the latest container running for more than 2 hours. It is still offline. Here are the logs from the latest container:
2019-10-07T08:10:53.449Z INFO Configuration loaded from: /app/config/config.yaml
2019-10-07T08:10:53.495Z INFO Operator email: REMOVED
2019-10-07T08:10:53.496Z INFO operator wallet: REMOVED
2019-10-07T08:10:54.913Z INFO version running on version v0.22.1
2019-10-07T08:10:54.944Z INFO db.migration Database Version {“version”: 25}
2019-10-07T08:10:54.956Z INFO contact:chore Storagenode contact chore starting up
2019-10-07T08:10:54.957Z INFO Node 1efZFqDdwMmzCaK3PtfKTmRdR2BXP1LHFe7a36P3cM7xuqnp4N started
2019-10-07T08:10:54.957Z INFO Public server started on [::]:28967
2019-10-07T08:10:54.957Z INFO Private server started on 127.0.0.1:7778
2019-10-07T08:10:54.962Z INFO bandwidth Performing bandwidth usage rollups
2019-10-07T08:10:55.018Z INFO piecestore:monitor Remaining Bandwidth {“bytes”: 3993326812160}
2019-10-07T08:10:55.221Z INFO version running on version v0.22.1
2019-10-07T08:25:56.262Z INFO version running on version v0.22.1
2019-10-07T08:40:56.319Z INFO version running on version v0.22.1
2019-10-07T08:47:08.747Z ERROR contact:chore pingSatellites failed {“error”: “rpc error: code = Unavailable desc = transport is closing”}
2019-10-07T08:55:56.374Z INFO version running on version v0.22.1
2019-10-07T09:10:54.962Z INFO bandwidth Performing bandwidth usage rollups
2019-10-07T09:10:56.288Z INFO version running on version v0.22.1
2019-10-07T09:23:47.929Z ERROR contact:chore pingSatellites failed {“error”: “rpc error: code = Unavailable desc = transport is closing”}
2019-10-07T09:25:56.262Z INFO version running on version v0.22.1
2019-10-07T09:40:56.263Z INFO version running on version v0.22.1
2019-10-07T09:55:56.256Z INFO version running on version v0.22.1
2019-10-07T10:10:54.962Z INFO bandwidth Performing bandwidth usage rollups
2019-10-07T10:10:56.232Z INFO version running on version v0.22.1
2019-10-07T10:22:30.882Z ERROR contact:chore pingSatellites failed {“error”: “rpc error: code = Unavailable desc = transport is closing”}
2019-10-07T10:25:56.322Z INFO version running on version v0.22.1
2019-10-07T10:40:56.232Z INFO version running on version v0.22.1

My script for launching the container is as follows:
docker run -d --restart unless-stopped -p 28967:28967 -p 14002:14002 -e WALLET=“REMOVED” -e EMAIL=“REMOVED” -e ADDRESS=“REMOVED” -e BANDWIDTH=“4TB” -e STORAGE=“12.6TB” --mount type=bind,source=“C:\Users\STORJ\AppData\Roaming\Storj\Identity\storagenode\”,destination=/app/identity --mount type=bind,source=“E:\data\”,destination=/app/config --name storagenode storjlabs/storagenode:beta

I have also confirmed that docker is up to date and all windows updates are up to date. Any ideas on how to get my node up again?

1 Like

Since you updated docker you need this

Run powershell as admin
`New-NetFirewallRule -DisplayName “Storj v3” -Direction Inbound –Protocol TCP –LocalPort 28967 -Action allow

Also I would recommend using \\ instead of single \ in your path and removing the \ at the end so your path should be C:\\Users\\STORJ\\AppData\\Roaming\\Storj\\Identity\\storagenode & E:\\data

Hi nerdatwork,

Thank you for your response.

I have a manually created firewall port opened for the inbound port 28967 as stated in my original post. I did however see this powershell command in another post and I tried it before posting in the forum. It created a rule identical to the manually created rule just with a different name.

The windows paths in my script all have \ separating each folder or drive but for some reason when i posted it removed one of each separator to a single . When using the single \ the paths are not mapped to the container anyway, i discovered this when initially setting up the node.

Anything else i can try?

1 Like

I’m not an expert by any means on Storj, but have you checked your outgoing firewall rules? I’d assume a ping might use ICMP but again I’m not sure specifically how they do their checks. However, I have my nodes wide open for outgoing traffic.

The “pings” happen over the same protocol that the satellites use to communicate with the node. ICMP is not required to be open.

1 Like

Thank you every one for your assistance. The problem was my router stopped updating the DDNS service. This was due to a firmware update which added an interval to the script which previously was a set interval of 5 mins. After the update it would only update the DDNS on startup and without the interval set would not update when the IP address changed. I have set the interval to 5mins as it was before and my node is online again. Aleksey from Storj Support asked me to confirm the IP addresses matched between my WAN IP to the DDNS IP address. I was using a port scan tool that automatically added my WAN IP so was not actually filling in my DDNS address. Silly mistake on my part. For anyone using a Mikrotik router with recent firmware, the IP>Cloud section now has an interval which needs to have a time set ie. 5 or 10mins.