Node offline created from docker on synology

Hi, im new in the comunity and i have spend a few hours reading about this problem but i can’t fix it.

I wanna run 2 different nodes on my synology nas. The first pointing to the port 28967 and 14002 works fine but when i run the second the port 14002 redirected to the 14003 works fine but the node is offline and seems that the port foward from 28967 to 28968 doesn’t work fine.

On docker config panel, at the snap of port configuration I set local port 14003 and 28968 and container port 14002 and 28967. On the enviroment I set myip:28968.

I try setting myip:28967. myip:28968, on port configuration 28968 to 28968… any configuration works to set this node online.

Could you show the docker run command you are using to start your node? You can remove any personal stuff you don’t want to share.

I’m using the Synology interface so I don’t use the command interface.

sorry, 2 pics in 1 due to the limit by new user

Please don’t use this GUI to create the container. It will use volumes instead of bind mounts, which is very dangerous and could lead to your node being disqualified. Simply connect over SSH and follow the CLI instructions in the docs.

I did spot your mistake in the screenshot. The container port is set to 28968 instead of 28967. Fixing that will get your node online, but you shouldn’t fix it here or you will be back here soon asking about how to fix a disqualified node. (Spoiler: you can’t, you’d have to start over)

Before post I tried to set the container port to 28967 too but doesn’t work.

I will fix this and recreate the docker by comand and check what happens

1 Like

I create the docker manualy without gui and i’m getting the same problem

docker run -d --restart unless-stopped --stop-timeout 300 -p 28968:28967 -p :14003:14002 -e WALLET=“0x0000000000000000000000000000” -e EMAIL="" -e ADDRESS=“IP:28968” -e STORAGE=“0.5TB” --mount type=bind,source=/volume2/NAS/StorJ/Nodo2/storagenode,destination=/app/identity --mount type=bind,source=/volume2/NAS/StorJ/Nodo2/datos,destination=/app/config --name StorJ-nodo2 storjlabs/storagenode:latest

i think that the command is fine

Please use the command exactly as instructed in the documentation. DO NOT use the :latest tag, it won’t work. You need to actually use the :beta tag as listed in instructions. However, by using the wrong tag you most likely already messed up your databases. Has this node ever received data yet? If not, you can simply remove everything from the storage folder, remove the container and start with the correct command. If your node has already received data, don’t do this or you will be disqualified.

neither, replaced the image latest to beta and same situation

i see at the log this line
Public server started on [::]:28967

if i set ADDRESS=“IP:28968” not be runing on 28968 port?

No, the server inside the container still runs on port 28967. You’re forwarding 28968 outside of the container to 28967 inside of the container. Have you doublechecked your port forwards, add exception to firewall etc?

Ports checked, other applications running fine (and other dockers too)


also checked with some tools that this are opened outside the network

I dont know why but i request new tokens and redo all the dockers and setting my ip instead the domain everything works fine.

Thanks for the help!