Node offline when using different port than 28967 (windows GUI, debian docker)

This find could (maybe) save someone few hours spent on trying to figure out why their node is OFFLINE when you specified different port than DEFAULT listening port.

When you:

  • checked firewall (even disabled for testing) - it should work fine - other applications work
  • you set up port forwarding on your router (it is OK), even turned off firewall - other applications work
  • You check your other ports with online port checker your port)
    One of the solutions that might be keeping you OFFLINE
    Well… check config.yaml file - It happened to me twice now - when I installed the node via windows GUI client ( and Debian docker) and specified DIFFERENT listening port --> this change DOESN’T propagate to config file.

When you run it, it still uses DEFAULT listening port, you have to edit the config.yaml file to correct the port number.
Then rm node and reacreate it (for docker users) or just restart service for windows GUI users.

This is expected result. The docker version uses an environment variables to get useful configs. So, you do not need to change the internal port in the config.yaml of docker setup unless you uses a host network instead of default NAT.
Usually you should change only a left part of the port mapping (external port), but not the internal one, because each container is isolated from the network (in the default usage): -p 28968:28967

You should NOT modify the port in the config.yaml unless you using a Windows GUI.

The Windows GUI is not a docker container, it’s not isolated from the network, so, you must change the port in case of the second Windows GUI setup on the same host. And do not need to do so, if these setups on different machines in the network: you can forward the 28967 to the first machine on 28967 and 28968 to the second on 28967 too, because they are on different machines.
You can read more there:

Yep Alexey, thanx for the response.

It was late at night (3 or 4 am after 6 hours of "tinkering with that @#@#%@#@ setup) and was really stumped by that “miss” behavior on windows.
Then when I tried to create similar node on linux - the same situation happened. And changing config file worked also.
But yes the best way is to not change listening port in config file, but to just forward the different public port to default port.