Node on Synology is offline and has QUIC misconfigured

I’m also having QUIC issues on my Synology - copy of error error
Can anyone point me in the right direction?

Hello @craigfer ,
Welcome to the forum!

You actually have two issues:

  1. Your node is offline. You need to fix that: My Node is OFFLINE for 2 hours - #2 by BrightSilence
  2. You need to configure QUIC: QUIC requirements | Storj Docs

Thank you. When I try the this docker exec -it storagenode ls -l /app/identity

I get this error

Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get “http://%2Fvar%2Frun%2Fdocker.sock/v1.24/containers/storagenode/json”: dial unix /var/run/docker.sock: connect: permission denied

You need to run docker commands with sudo

Thank you again Alexey. It looks like my identiy is ok? sudo docker exec -it storagenode ls -l /app/identity
-rwxrwxrwx 1 1026 users 558 Mar 15 05:28 ca.1647322123.cert
-rwxrwxrwx 1 1026 users 1088 Mar 15 05:28 ca.cert
-rwxrwxrwx 1 1026 users 241 Mar 15 05:28 ca.key
-rwxrwxrwx 1 1026 users 1100 Mar 15 05:28 identity.1647322123.cert
-rwxrwxrwx 1 1026 users 1630 Mar 15 05:28 identity.cert
-rwxrwxrwx 1 1026 users 241 Mar 15 05:28 identity.key
-rwxrwxrwx 1 1026 users 32768 Mar 15 05:28 revocations.db
total 56

Perhaps. Please, check remaining, especially - WAN IP on your router and on yougetsignal

I think this my be due to my location in Dubai and the service provider equipment (DU)
I have ADSL router that powers the CAT network in my apartment. One of the the ethernet wall ports has a LINKSYS VELOP system that powers the WIFI. Velop Whole Home Mesh WiFi: Strong WiFi Everywhere | Linksys
The SYNOLOGY unit is linked to the ADSL router. Anyone else in the United Arab Emirates have this problem?

Do you have an access to your ADSL router?
If so, please, login to it and open a status page. There is should be WAN IP. Please write it down.
Open Open Port Check Tool - Test Port Forwarding on Your Router and compare the WAN IP with IP there. If they don’t match, the port forwarding will not work.
If so, you have a few options:

  • Call to your ISP and ask for the public IP, it could be dynamic, but must be a public (the WAN IP will match the public IP on yougetsignal). You can say that you need to have an access to your security cam from everywhere, this will allow you to do not explain Storj to the ISP’s staff;
  • Switch to ISP, who offer a public IP;
  • Use VPN services with port forwarding feature, such as, ngrok, PIA, PureVNP, AirVPN, etc.

If the WAN IP matches the public IP, then you should check your port forwarding rule, it should forward TCP+UDP 28967 port to the IP of your Synology. You also need to add this port for TCP+UDP to your firewall for inbound traffic. You should not create an outbound rules.

1 Like