Node suspended on ALL sattelites!

Hey guys.
My node just got suspended because I was running 1.33.1 (very outdated version)!
My question is:
Why doesn´t this trigger an email stating running an outdated version?!
This would be avoidable with such email and warn the node operator to at least check what´s going on.
For some reason the watchtower command to auto-update is not working on my Synology :frowning:

1 Like

An email notification would indeed have been great, maybe at the moment your node stops receiving data (which it did 2 updates ago). I know there has been some trouble getting some of the emails to work reliably though. So they may not be to keen on introducing too many emails.

I run three nodes on Synology as well and watchtower is working just fine. Could you share the command you use to run watchtower? Do you have a single node or more than one?

Luckily you can recover from suspension by updating and just staying online for about 2 weeks. So no permanent harm done.

Both those screenshots show europe-west-1

Yeah, but I got a bunch of emails stating different satellites, 1 per each :frowning:

Yes, I know, but still…at this point is the project, one would assume this would be like “default” behavior!
I run 4 nodes:
2 Synology
2 Windows
Strangely enough, my other Synology runs like clockwork :s

If it’s 2 nodes on one synology, you may simply be missing the container name of the second node in the watchtower command. But it’s a little hard to help debug without seeing the command used.

It´s 2 separate nodes on 2 different Synology.
Run command:
sudo docker run -d --restart always --stop-timeout 300 -p 28969:28967
-p 14002:14002
-e WALLET=“xxxxxxxx475891a3cf5cdc07ec1928f8149093cef3”
-e EMAIL=""
-e STORAGE=“7.4TB”
–mount type=bind,source=/volume1/Storj/Dados,destination=/app/identity
–mount type=bind,source=/volume1/Storj/Storage,destination=/app/config
–name storagenode storjlabs/storagenode:latest

I was referring to the command of watchtower.

Should look something like this:

docker run -d --restart=always --name watchtower -v /var/run/docker.sock:/var/run/docker.sock storjlabs/watchtower storagenode watchtower --stop-timeout 300s

It would also be useful to see some logs for watchtower, before you restart it. Please run:

docker logs --tail 30 watchtower
1 Like

I´m using the watchtower run command from documentation: Software Updates - Node Operator

I´ll restart the watchtower logs when I arrive home and post here.
Thanks in advance.

I don´t have any logs:

Are you sure it’s running?

docker ps

I´m sure it´s running.

And did you use


before the command to run the watchtower? (Synology requires “sudo”)

sudo docker run -d --restart=always --name watchtower................

Just enter here what exactly you write to run, and do not refer to the page where an example of such a command is given …

This shows you just created it?

Here or goes:

sudo docker run -d --restart=always --name watchtower -v /var/run/docker.sock:/var/run/docker.sock storjlabs/watchtower storagenode watchtower --stop-timeout 300s

Yes, I deleted the container several times trying to make it work.

Watchtower doesnt do anything when its first installed though you have to wait for it to go though its process.

You can make it log more by adding --debug at the end of the command. Maybe that will show you something in the logs.

Nothing :frowning:
–debug command does not work.
Tried --details and got nothing in return.


You need to stop and remove the watchtower container then run it back with all parameters include changed one:

1 Like