Nodes Offline!?

This is the complex part, at least with respect to node operation. That seems to be the one thing that is causing problems, as you had said yourself that it seems to be a routing issue. If the routing from each port to each docker container is done properly, there’s no reason that the node software itself should have a problem as it knows nothing outside of what you provide to the container. I really do wish you luck as I am sure this will work when properly configured, but it’s beyond my experience.

2 Likes

Thanks, anyway! Started from scratch with new identities… Node 4 up. 1, 2 and 3 remaining… It was just that the identity was calculated faster. :smiley:

Might be easy to do for someone with experience but it sure does add more “points of failure”.

Maybe the problems have something to do with the identity, at least I hope that’s what it is, it would be an easy fix !

EDIT: points of failure probably isn’t the right term

1 Like

Hope so. Starting from scratch would show. Doing now, but generating keys on 2x Intel(R) Xeon(R) CPU E5-2650L v2 @ 1.70GHz, 40 cores seems to take forever…

1 Like

are all cpu resources used ?
Last time I generated identities it wouldn’t use 100% of the cpu but I don’t really know why. It’s kind of a gamble though, once it took me only like 40 min on a raspberry pi and another one took 1 day on my laptop…

Yes. I was kidding. Takes from several mins to less than an hour. 1 was already generated and the other 3 are at diff 34 (36 required). It is 40 cores after all. :smiley:

1 Like

How long does it take you to get a new token for the same email? They are single use only. When should I retry? Tried now and it generates the same auth token. I would like to use the same email for a reason - get all notifications from all nodes there.

And we have a winner! ERROR contact:service ping satellite failed again on the 2nd node…

it will give you a new auth token when you have used the one you was given, the reason you get the same one is because you haven’t signed an identity with that one yet.

2 Likes

Makes sense. Thanks!

suspension also doesn’t matter much, especially for troubleshooting…
if you want to make new nodes i would still test on the old ones until you got the network behaving correctly.
then after that maybe using the new nodes makes sense, i don’t think so but its possible, suspensions can be rather long… but then again sometimes they seems to go away fairly quickly also…

It does behave correctly. Maybe it was some docker screwup. That’s why I start over. To make sure it works properly. Hopefully when it is done and server rebooted, all starts up as expected. Have to make sure this is so, in case of kernel update, etc.

I think the issue is that you use old CPU E5-2650L, this probably not got enough cores to run node as they seem to work better on 128 core system, are you able to upgrade ?

While you waiting for Identity’s to generate, might be worth having a read on docker.io about docker-proxy, it might answer some of your questions, or raise more :slight_smile:

Also, as others mentioned, your setup is complex, but I’m sure someone will be along to tell you how to fix this :popcorn:

3 Likes

The fun thing is that I’m trying to optimize my setup and I’ll probably run into the same issues :rofl:

Storj is just kind of an excuse for me to learn these things but I’ll have to do quite a bit of homework because I’m not familiar with all of this networking stuff.

I’ll keep an eye on this thread !

:rofl:

Will check. Thanks!

I thought I knew Linux networking. Dealing with it for 18+ years… But docker… Docker is a piece of… :slight_smile:

Expect a couple of DMs from me asking for help when you’ll have it figured out because I’m definitely out of my comfort zone with this haha

Sure. Np. Should eventually work out.

2 Likes

Similar problem, so solved like this. ERROR contact:service ping satellite failed? - #26 by svet0slav

1 Like