Open Ports, Node Offline

I’m running a Win10 laptop, I have everything setup. Using the tool checker, my 28967 port is open. After setting up everything else, the dashboard says I’m offline. I’m not sure what I missed, what can I change so that this can become online?

did you signed idendity with Stroj sended to your email key? check your port open from outside, may be your provider hold ports closed.

Yes, I got the key, generated my identity, got a 2 and 3 count.

And checking my port, its open

Which browser are you using to check your dashboard ?

Chrome, should I try something else?

Chrome/Firefox/Edge is good. Can you show last few lines of the log ?

I see 1 error:

2020-08-13T04:11:13.739-0800    INFO    Configuration loaded    {"Location": "C:\\Program 
Files\\Storj\\Storage Node\\config.yaml"}
2020-08-13T04:11:13.769-0800    INFO    Operator email  {"Address": ""}
2020-08-13T04:11:13.769-0800    INFO    Operator wallet {"Address": ""}
2020-08-13T04:11:14.494-0800    INFO    Telemetry enabled
2020-08-13T04:11:15.147-0800    INFO    db.migration    Database Created        {"version":     43}
2020-08-13T04:11:15.461-0800    INFO    preflight:localtime     start checking local system     clock with trusted satellites' system clock.
2020-08-13T04:11:16.559-0800    INFO    preflight:localtime     local system clock is in sync     with trusted satellites' system clock.
2020-08-13T04:11:16.569-0800    INFO    bandwidth       Performing bandwidth usage rollups
2020-08-13T04:11:16.578-0800    INFO    Node 12DLiPWfUZRTLggWsFysuQD4mYdZ6xnsSS2FqanKvXRALaW4z75 started
2020-08-13T04:11:16.578-0800    INFO    Public server started on [::]:28967
2020-08-13T04:11:16.578-0800    INFO    Private server started on
2020-08-13T04:11:16.579-0800    INFO    trust   Scheduling next refresh {"after": "6h6m31.119195636s"}
2020-08-13T04:12:33.394-0800    ERROR   nodestats:cache Get disk space usage query failed       {"error": "node stats service error: unable to connect to the satellite 12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs: rpccompat: context deadline exceeded", "errorVerbose": "node stats service error: unable to connect to the satellite 12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs: rpccompat: context deadline exceeded\n\*Service).dial:156\n\*Service).GetDailyStorageUsage:107\n\*Cache).CacheSpaceUsage.func1:176\n\*Cache).satelliteLoop:259\n\*Cache).CacheSpaceUsage:175\n\*Cache).Run.func3:131\n\*Cycle).Run:92\n\*Cycle).Start.func1:71\n\*Group).Go.func1:57"}
2020-08-13T04:55:57.381-0800    INFO    Interrogate request received.
2020-08-13T05:11:16.569-0800    INFO    bandwidth       Performing bandwidth usage rollups

Try the checklist too:

it is posible that your firewal prevent storagenode service from access internet. add storagenode service to firewall fot otgoing

I looked at my config file and saw this

total allocated bandwidth in bytes (deprecated)
storage.allocated-bandwidth: 0 B

Not sure if I have to adjust that manually. Also, when I tried the:

stop-service storagenode

It gave me an error:

Stop-Service : Service 'Storj V3 Storage Node (storagenode)' cannot be stopped due to the following error: Cannot open
storagenode service on computer '.'.
At line:1 char:1
+ Stop-Service storagenode
+ ~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : CloseError: (System.ServiceProcess.ServiceController:ServiceController) [Stop-Service],
+ FullyQualifiedErrorId : 

Are you running powershell with admin rights ?

I started up powershell with admin, and the commands worked.

So, my ports are still good, and it was say if those are good, then it’s my identity. I got a 2 and 3 for my counts, but it also mentioned I should have 6 files. I only have 5.



ca.##.cert --- 1kb
ca.cert --- 2kb
indentity.##.cert --- 2kb
identity.cert --- 2kb
identity.key --- 1kb

I did move the ca.key to my other storage device.

Are you using static ip or DDNS for contact.external-address ?

if you stop the storagenode service is your port still open?

The command doesn’t work when I use


I also noticed that the ip for my laptop is the same as desktop, I’m not sure if that is affecting it. When Igo to what’s my ip on my laptop, is the same ip when I go on my desktop. The local ip (192.168.X.X) are different.

My ports are still open when I stop the node

Then your port forwarding is wrong. Please, check to where you forwarded the port.
Also, any device in your network must have a different IP, so the laptop should not have the same IP as your desktop.

The contact.external-address parameter should be specified in your "C:\Program Files\Storj\Storage Node\config.yaml" config file. It should contain your external address (either public static IP or DDNS hostname) with port, i.e

contact.external-address: external.address.tld:28967

I got it working. I closed my port forwarding software, that seemed to be the cause of the problem. I after I closed that, I stopped my node, and checking the port, it was closed. Turning back on the node, port is open, and my dashboard is online.

My fault for trying to force open my port :sweat_smile:

What kind of virus or ransomware you have installed?

1 Like

==The link is eliminated==

Please, do not install ransomware
You do not need to install any software to make a port forwarding on your router. What you really need - is to go to the main page of your router and create a rule yourself.