Preflight database error: piece_expiration: expected schema does not match actual

Yes, update your docker run command:
Also, do not use a network connected drives for the storage.

Ahh, we changed back from -v to --mount? I will change that!
Also, concerning the Notice:

Linux Users: You must static mount via /etc/fstab. Failure to do so will put you in high risk of failing audits and getting disqualified. Here’s how to do that.

As I have had very bad experiences in changing things in the fstab, I’d rather not do that directly. I made a mount on startup through the Centos7 disks utility (linked with the UUID of the device) as I thought this would make an fstab entry for me. Is that solution acceptable or is this exactly what is not advised?

Please, give me result of the command

df -h

Almost a year ago. We have not had the --mount before

Ahh, I see. The --stop-timeout 300 flag is now used in the run command. I will add that asap.

$ df -h
results in:

/dev/sdb1 4.6T 281G 4.1T 7% /media/user/storj_drive

Thanks for the great support, Alexey!

1 Like
grep "/media/user" /etc/fstab

$ grep "/media/user" /etc/fstab

/dev/disk/by-uuid/6fea7213-3728-434b-aba3-3704dcd94942 /media/user/storj_drive auto nosuid,nodev,nofail,x-gvfs-show 0 0

It looks like properly mounted

1 Like