QUIC Misconfigured in v1.67.1

My Node Status:

One was auto-upgraded to v1.67.1 another still v1.66.1

Ubuntu, docker

Both work fine.

If problem still affects many node operators, should Storj temporarily pause the auto-upgrade? Is that possible? @Alexey

At least until we know the exact cause and have a fix?

Same issue for one of my two nodes, which got upgraded to v1.67.1. The other node shows that QUIC configured correctly, but the one which got upgraded started to show this error. No changes were made to router or node config (otherwise node which did not upgrade yet would also show same error).
I also went to RDP to server and checked if corresponding ports are opened via site, and site reports that they are opened.
Tried to restart node and now it shows QUIC as correctly configured, but judged by other replies it may report error again later.

5h in after restart of node - error did not appear again.

Same problem, I changed nothing and verified the port forwarding, QUIC was showing OK on all nodes until upgraded by Storj to 1.67.1

A post was merged into an existing topic: Current Month Earnings in Node V1.67.1

Mine is still up after 46hr, my restart was a stop -t 300. And, a full server update and reboot.

If after upgrading to 1.67.1 QUIC Misconfigured appears, it is enough to press the F5 key to “fix” it :rofl: The Reload key inside the page does not help, but F5 solves all problems except for the wrong Current Month Earnings, and for that we will wait for a newer version…


Wow, it works, QUIC is green again :rofl:

1 Like

On a NAS with Docker, I run 2 nodes on 2 disks. The watchtower is set to update both nodes. How can one be at 1.67.3 and the other at 1.66.1? Dosen’t it update the storagenode:latest image for both in the same time? I don’t know how linux works…

There should be some kind of mechanism in the node software/network that make sure the rollout of every new version is gradual.

And for a good reason: in case the new one has a bug, it doesn’t affect the whole system at the same time.

My updated node is also showing QUIC Misconfigured. Is this also a visual bug?

1 Like

I have this as well but after SYNOLOGY DSM update. Running under Docker.

To answer my own question, I’d say yes. A refresh of the page fixes QUIC.

EDIT: I mean a refresh of the browser page fixed QUIC. Refreshing the dashboard using the top left button did not fix QUIC. Just saying…


and the version with a fix is in rollout:

See https://version.storj.io/

Please note that we already are doing the rollouts of each new release in small batches, not all at once for all nodes for the exact reason you just stated.

checked on my node today after about a week and everything was okay.

10 minutes later the QUIC changes to “misconfigured” seemingly out of nowhere. I didn’t even restart the PC. All I did after checking it was go to a few webpages and check discord.

I noticed the “uptime” and “last contact” were identical when I first checked the node. They both said “144 hours”. I do not think last contact could have been 144 hours ago because my online percentage didn’t change. I don’t know if these are unrelated issue.

I have “both protocols” set up on my router.

Well this is not my case :slight_smile: I have tried everything (restarts, change router, recreate router rules, recreate nodes etc…). See here:


3 posts were merged into an existing topic: Database disk image is malformed - Error coming from nowhere

Why don’t you all do a manual update to 1.67.3? It seems all the quick errors come from 1.67.1… so, manual update.

We rolling out new versions by waves to do not shutdown the network.
So please be patient, it will be updated when its time to come.

Don’t tell me to be pa… oh wait it came already.

1 Like