Raspberry 3/4 Node Owner - Did you do any optimizations?

@LinuxNet You mention Raspian x64 …? Can you point me at the image please as I can’t find it? :thinking:

My standard Raspian image reports armv7l so 32bit…

Thanks!

Unfortunately x64 is not yet officially available. But you can easily switch to 64bit

execute via ssh sudo rpi-update then insert arm_64bit=1 into /boot/config.txt and restart the Pi.

Check with uname -a

@paulie1001 I will report tomorrow.

2 Likes

Nice one @LinuxNet - Thanks ! Done.

I’ll see if it makes any obvious difference over the next few days…

@LinuxNet Have you tried the new Ubuntu 20.04?

So far I can see no real difference between Raspian x32 and Raspian x64. Even a new SD card makes no difference. Neither with the RPi3 nor the RPi4. The fact that my success rate will decrease is more likely due to the new second node at home because now every node has only a 50 percent chance of winning the race.

Unfortunately, Raspian x64 is still not supported by all packages and sometimes still recognized as a 32bit system.

My new Raspi 4 comes next week where I install Ubuntu x64 again. Then I can compare both systems live.

@VinC No, I had / have Ubuntu 18.04. The image was adapted to the RPi 4 with 4GB. Google -> Raspberry Pi 4 Ubuntu Server / Desktop 18.04.4 Image (unofficial) from Jameschambers

did u try raspbian buster lite and add “arm_64bit=1” to the /dev/config.txt ?

Sure. see my screenshot 6 posts above.

Edit: not in /dev rather /boot

No, I had / have Ubuntu 18.04. The image was adapted to the RPi 4 with 4GB. Google -> Raspberry Pi 4 Ubuntu Server / Desktop 18.04.4 Image (unofficial) from Jameschambers

Thanks for this info, is this stable enough for production use? Would like to try it on my next node.

I only used it until 18.04.2 and it was very stable. I only had one problem with Unbound and PiHole which is why I switched back to Raspian at some point. However, I will install version 18.04.4 on my new RPi next week. The last update is from February.

This doesn’t sound right: the added node will half the chance of the first node to participate in a race (by stealing the second half) but once it enters the race the success rate should remain almost the same (of course if the network link did not become the limiting factor).

2 Likes

Oh ok then I misunderstood. Thanks for the clarification and sorry for the wrong information! For the rest, I don’t notice any difference with the “old” node. With almost 250GB of traffic, both nodes are the same this month.

Unfortunately, I cannot determine the success rate for my new node. The script only prints zeros.

I am sorry for late answer :smiley:
No unfortunately, it was this much only in January and around 100USD in December when they were heavily testing the network. Now it is more like 10USD per month. But it still pays for the electricity and I earn at least 5USD.
What about you? How much are you earning lately? :slight_smile:

RaspberryPi OS64bit is now available
https://www.raspberrypi.org/forums/viewtopic.php?f=117&t=275370

3 Likes

Where can i find my logs once i executed the instructions? Might be a stupid question but i can’t find the /app/config/node.log

You find them on your bind path. You specified it in the mount option of your docker run command.
For example, /mnt/storagenode/node.log

1 Like

Thanks. Is it safe to open the logs with nano while the node is active?

Yes, as long as you don’t change the log, that’s no problem.

1 Like

A post was split to a new topic: Have 0 % UPLOAD success rate!

Haha some guys just hijacked the thread xD

@MadeInGermany have you tested the SATA hat? Have you got better results?

9 posts were split to a new topic: I am interested in an making a sat from a rpi