Raspberry pi "bricks" after Install

I tried to install on a raspberry pi 4 and when it rebooted it got stuck showing the 4 raspberries. I figured something was inputted incorrectly during the install process. I tried it again on a raspberry pi 3 b+ remotely and it went unresponsive. I completed the steps up to creating the node identity. I suspect it may have something to do with the cgroup memory addition? Seems like the only critical setting thus far.

I’m following https://support.storj.io/hc/en-us/articles/360026612332-Install-storagenode-on-Raspberry-Pi3-or-higher-version

Any other settings or tweaks I should be aware of?

Thank you!

1 Like

Hello and welcome,
Im a bit curious when you say you brick your rpi4
What do you mean?

I have successfully ran 3 rpi4s with storagenodes and they have been really stable. So Id be curious as to what you may have done, and possibly I can help you correct the issues.

One of my (non-storj) raspberry pi’s ‘exploded’ last month, the sd card just stopped working correctly and no matter how many clear fsck’s I did, it wouldn’t work correctly. Put the SD Card in the bin, re-installed with a new card and it’s been fine since. SD-Cards seem to go wrong with little notice. If you’re running a storagenode on a raspberry pi (with an sd-card), ensure everything on that sd-card can be re-installed if the card needs to be replaced.

AFAIK the SD card is only really needed for the Broadcom bootloader…

Once the bootloader has been run, the OS can be loaded from an external drive. That should save wear and tear on the SD card.

Haven’t tried it, but here’s a ZDNet tutorial:

Raspberry Pi 4’s don’t even need SD Cards for the bootloader as they have enough firmware to boot from USB directly (and PI 4 compute modules have other alternatives).
I’m still using sd-cards for all my pi’s as I still haven’t worked out a method of monetising my 2+ year storj payments into anything I can actually use - though that’s another story…

You can now update the firmware on rpi4 to just boot from USB. I did it cause I got sick of all my sdcards dying…

1 Like

You must have thousands of tokens…

If you want to buy stuff, you can find plenty of options on coinsbee … as long as you have enough ETH to pay for the transaction.

Hahahaha, About 90 and no ETH…

1 Like

Sorry to hear…

But I shouldn’t be hijacking the thread. I apologize to the OP…

@Bl2yan as @deathlessdd indicated - can you be a bit more specific on what your screen was showing when the RPi4 got stuck booting? or any error message on the RPi3 ?

It may be that your SD card is faulty… or maybe the OS image wasn’t copied completely onto the card.

1 Like

No worries - all good info. I downloaded a fresh copy of OS lite and will be trying again tomorrow. I have a handful of pis left over from a project as well as 3TB hard drives from raid arrays I’d like to put to use.

I appreciate the replies and will update on progress tomorrow.

I hope they aren’t re-badged Seagate Constellation’s!

a storagenode shouldn’t in any case crash your OS, its highly unlikely and like suggested most likely aggravated existing issues on the RPI’s.
since the sd card is an easy fix i would start there.

ST33000650NS Seagate Constellation ES.2 3TB
i got 11 of these running for the better part of a year and they are like antique, no problems what so ever and they have 63000 power on hours, so it’s certainly not all of them that seems to be an issue with, ofc there are many different minor model variations which may have issues, or i just got lucky.

had gotten them in the beginning of the year so i got rather worried when i saw this video, but
thus far they’ve been feed a hot supper and show no signs of trouble.

I’ve got some HP 2TB’s that are re-baged Seagate’s that failed within a couple of days of installation. No problems getting refunds from the ebay sellers though after providing evidence.

1 Like

I haven’t installed on a Pi, so apologies if this isn’t helpful. But when you say “up to creating the identity” - I seem to recall that you should do all of it on a desktop/laptop, and then transfer the resulting files afterward.

I downloaded a new copy of OS lite and I haven’t experienced the issue anymore. It was online for about a day and the usb drive unmounted. They aren’t the constellation drives haha. Going to work on getting the other 5 pi nodes up and see how they do.

Thanks for all the replies!

1 Like

Just a note…

It’s strongly advisable to use a separate power supply for the HDD or HDDs.

The RPi shouldn’t be used as the main power source for USB connected HDDs. If the HDD is being constantly accessed, the RPi power supply might not be able to keep up with the current demand leading to unstable USB behavior.