Rsponsive dashboard for mobile devices


I was running 0.33.4 Node and I was able to acces my dashboard on my phone with Chrome (at least I have to check “Computer version” in parameters).

But after my Node’s upgrade, dashboard is not displayed nicely on both way (“Computer version” checked or not) :

“Computer version” checked :

“Computer version” unchecked :

1 Like

It’s not responsive, but it should work when desktop mode is on. This looks like a CSS caching issue, clear browser cache and try again.

A feature suggestion for a responsive dashboard is open on

1 Like

Thanks !

Cleaning cache do the trick :wink:

1 Like

You normally have to clear cache after the node is upgrades, it’s been this way since the new design of the dashboard.

True, clearing the cache does solve the display issue

However, even though it’s quite easy to fix on desktop computers by pressing Ctrl+F5 or similar, clearing the cache on mobiles is a pain: we need to know where to look in the settings, and it may take a bit of time to complete on some devices… and this needs to be done each time a new version comes out.

This shouldn’t be necessary.
Some modern websites target generated css files whose name changes everytime a new version comes out. That solves the cache issue as a new css filename implies a file that is not known by the browser yet.

StorjLabs should consider such a mechanism, I think :slight_smile:
Or at least, css files shouldn’t cached for long. 1 hour maybe?

1 Like