S3 Gateway Questions

I’m working through the S3 Uplink documentation. And I am at the step “Configure using an Access Grant” and it says to use this command…

./uplink share sj://site

When I do this, I get an error that says, “Invalid Access Grant Format” and I am using the latest binaries as of today.

I went into the Gatewat yaml config, and found the access string, and added a command so it was like this…

./uplink share sj://site --access

And that worked. But I’m not sure if what I did was right, or even necessary. Has something changed and obtaining an access grant via the uplink is no longer necessary? Or should I be getting this access string from somewhere else? Confused. I ran through this a couple weeks back with older binaries and this error didn’t happen in the uplink, so I realize something has changed in this process. (And our documentation is wrong)

1 Like

The issue seems with uplink's config.yaml. Looks like you do not have a default access in the ${TheExactPathDependsOnOS}/uplink/config.yaml

So, you can import your access grant from the gateway/config.yaml to the uplink either via CLI:

  • For default access
./uplink import your-long-serialized-access-grant-string
  • For named access
./uplink import my-access your-long-serialized-access-grant-string2

or just edit the uplink/config.yaml and add the serialized access grant to there in a format:

access: your-long-serialized-access-grant-string # for default access
accesses.my-access: your-long-serialized-access-grant-string2 # for named access

save the config and use the uplink with it.

  • With a default access:
./uplink ls
  • With the named access:
./uplink --access my-access ls

Perfect! Thank you. It might be good if the error message detailed the nature of the problem a bit better, but it is what it is.