Setup 2. Node on raspberry fails

Hello Guys.
I just run last week my first Node on my raspberry online :sweat_smile:
I want to connect 3 further HDD to my raspberry 3b, do you think that this is too much for the raspberry? My connection: 50Mbit/s Up and 1000Mbit/s Down.

On my first 48hr i had 12GB Traffic, seems a bit low…

I just tried to run 2nd Node on the same raspberry but failed.
I created a new Key and Authentication and followed the steps on the storji-documentation. The Container is only running for seconds on the dashboard, then restart and after 5min exit.
I opened for the first Node the port 28967 TCP and on the scan he’s open.
For the 2nd Node i opened 28967 but the scan tell me that he’s still closed :sleepy:
Here are my settings:

sudo docker run -d --restart always --stop-timeout 300 \
-p 28968:28967 \
-p 127.0.0.1:14003:14003 \
-e WALLET="0x****************************" \
-e EMAIL="**************@gmail.com" \
-e ADDRESS="**************:28968" \
-e STORAGE="8TB" \
--memory=800m \
--log-opt max-size=50m \
--log-opt max-file=20 \
--mount type=bind,source="/mnt/storj2/Identity/storagenode",destination=/app/identity \
--mount type=bind,source="/mnt/storj2/Datenbank",destination=/app/config \
--name storagenode2 storjlabs/storagenode:latest

Maybe someone can help me? I had read that the port is only open when it is accessed… so maybe the first issue takes care of itself with the first issue?
Other Question: Do i need for every Node a new E-Wallet? That seem’s to be really stupid …

Thanks!

on your router, you need to port forward 28968 for second node.

that should be -p 127.0.0.1:14003:14002

Wallet address should be the same for all of your nodes.
E-mail address can be the same for all of your nodes.

I don’t export my logs out of docker, so I can’t comment on the

part of your run command.

1 Like

Sorry, my mistake. i opened 28968 for the 2. Node.
Still the same after changing to 14003:14002 …

Hello,
What is in the logs?

Why you use docker run -d --restart always???
In documentation is…
docker run -d --restart unless-stopped

BTW if you have one public IP is better to run only 1 storagenode and after this node is 80-90% full start next node…

1 Like

Because “i do the same as i did for the first Node”…
how i call the logs? After i send the command i wrote in the first Post:
"WARNING: Your kernel does not support memory limit capabilities or the cgroup is not mounted. Li mitation discarded.
1d88b1afe14e53b6d4c3096f375867ed738f9f18b37560f0e3163f7c6833da09
"

Setup the second node with https://documentation.storj.io/

Only nodes setup with documentation we can troubleshoot

There you can see how to check logs
https://documentation.storj.io/resources/faq/check-logs

I’d argue (and have done myself) to open up additional nodes if I have the hardware for it. My reasoning being to start the vetting process/held window on the nodes. This is done with the understanding that all nodes behind a /24 IP get logically viewed as a single node when the satellites are looking for nodes to take pieces for the purpose of geographic protection of the data.

I’m running an RPi3 with 3 drives (2G, 2G, 1G) attached to it. They’re all in one USB dock. No issues seen so far. Note I’ve omitted the --memory=800m from my docker run statements because the RPi3 only has 1GB of memory. Maybe this is where you’re having an issue?

Thats what i get evrytime:

2021-04-05T21:36:31.134Z ERROR contact:service ping satellite failed {“Satellite ID”: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE”, “attempts”: 11, “error”: “ping satellite error: check-in network error: failed to resolve IP from address: ******.ddnss.de:28967, err: lookup *******.ddnss.de on 10.124.0.10:53: server misbehaving”, “errorVerbose”: “ping satellite error: check-in network error: failed to resolve IP from address: *******.ddnss.de:28967, err: lookup ******.ddnss.de on 10.124.0.10:53: server misbehaving\n\tstorj(.)io/storj/storagenode/contact.(*Service).pingSatelliteOnce:138\n\tstorj(.)io/storj/storagenode/contact.(*Service).pingSatellite:95\n\tstorj(.)io/storj/storagenode/contact.(*Chore).updateCycles.func1:87\n\tstorj(.)io/common/sync2.(*Cycle).Run:92\n\tstorj(.)io/common/sync2.(*Cycle).Start.func1:71\n\tgolang(.)org/x/sync/errgroup.(*Group).Go.func1:57”}

editet the links because i can only have 2 per post.

i fixed that now. gave only 200m for the 2.(only for testing) still doesnt working.
I get now only the state “offline”

Hello @elcoapon ,
Welcome to the forum!

Seems your DDNS address is mistyped. Please, check it in your first node. If this was logs from the second, please, make sure that you specified port 28968 in your -e ADDRESS option, because logs complaining on address with port 28967.

To check logs for the second node you need to use a name of the second node, i.e.

docker logs --tail 20 storagenode2

The --memory=800m option is to limit the RAM usage, it’s not a request. This option was needed in case if your memory usage can grow unlimited and Pi will hang. With this option the node will be killed instead.