Some download error messages after starting a 2nd node


I added yesterday a second node to my server after successfully filling in a first HDD.

I went through the process to create a new identity, added my auth token, and ran the following command:

sudo docker run -d --restart unless-stopped -p 28968:28967
-p 14003:14002
-e ADDRESS=“XXX:28968”
-e STORAGE=“7.0TB”
–mount type=bind,source="/home/XXX/.local/share/storj/identity/storagenode1/",destination=/app/identity
–mount type=bind,source="/storj1",destination=/app/config
–name storagenode1 storjlabs/storagenode:beta

Looking at the logs, I am seeing download errors such as the ones below:

2020-01-05T10:55:17.517Z INFO piecestore download started {“Piece ID”: “MHG5WVF6ILPMAHC75IYULPURBRLFK2PACZWGAP3YIQ7H7LQKOP4Q”, “Satellite ID”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “Action”: “GET”}
2020-01-05T10:55:29.033Z INFO piecestore download failed {“Piece ID”: “MHG5WVF6ILPMAHC75IYULPURBRLFK2PACZWGAP3YIQ7H7LQKOP4Q”, “Satellite ID”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “Action”: “GET”, “error”: “piecestore: piecestore protocol: write tcp> use of closed network connection”, “errorVerbose”: “piecestore: piecestore protocol: write tcp> use of closed network connection\n\*Stream).pollWrite:189\n\\n\*Stream).RawWrite:233\n\*Stream).MsgSend:266\n\*drpcPiecestoreDownloadStream).Send:1166\n\*Endpoint).doDownload.func3:643\n\*Group).Go.func1:57”}

2020-01-05T10:56:39.054Z INFO piecestore download started {“Piece ID”: “JHXMHCW3P4GM54555YBV4ULDWFKXPJ3WJMGCCPVATNIKHMLRFEHQ”, “Satellite ID”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “Action”: “GET”}
2020-01-05T10:56:43.664Z INFO piecestore download failed {“Piece ID”: “JHXMHCW3P4GM54555YBV4ULDWFKXPJ3WJMGCCPVATNIKHMLRFEHQ”, “Satellite ID”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “Action”: “GET”, “error”: “piecestore: piecestore protocol: context canceled”, “errorVerbose”: “piecestore: piecestore protocol: context canceled\n\*Endpoint).doDownload.func3:652\n\*Group).Go.func1:57”}

On the dashboard side, my node seems to be online, I get 100% audit checks on all Satellites, however uptime checks stand at 31.9% for all Satellites.

Is something going on that I should fix on my side?

Many thanks for your help :slight_smile:

Please, check your port forwarding rule, make sure it’s forwarded 28968 to the IP of your PC with storagenode and not mixed up with your previous node on the 28967 port.

you should use new ports everyware 28968:28968

WRONG- not Use it

Thanks Alexey, I checked my router config indeed and I can confirm that port 28968 is correctly forwarded to my internal IP.

I have just tried this but now the node is not even online any more…

do you have firewall on node? opened olso this port?

There must be something with the configuration of the 2nd node that I don’t get since the first one has always worked well…

One thought: I used the same email address for the second invitation. Could it be the reason?

no i have 10 nodes on 1 email

Are you only seeing download errors?
Ping your Port.
Restart Router and Node helps sometimes

Well I just restarted the node and I don’t seem to have download errors any more. Uptime also seems to grow now. Thanks and sry for the inconvenience!

Negative. Only left part, which is published on host. The internal port should be default, otherwise you will need to change it in the config. This is excess action.

1 Like