Start ~/

It seems to have fixed something. But then there is an error when running the script

That’s not an error, just a warning. You can ignore that for now. Your node should be running now. Try checking the web dashboard.

Ok. I think we are getting somewhere!

Looks like it’s running, but unfortunately still offline. Could you check your port again, now that the node is running?

Apologies for the delayed reply. I had reached my “limit” as a new member for number of posts in a day. My node still shows “offline” with an uptime of 16h 30m so far.

Could there be an issues somewhere in here under the “ports”

That looks fine. Might be an issue with your port-forwarding on the router

I believe it is. I have tried several different configurations on the router to try open the ports. I may have to switch it to a different network I have running. I would then have to change the internal IP address. Would I only have to change it in the ~/ file?

You do not need to change an internal IP in that command, it’s not used here.
You should put to the ADDRESS option your public IP or DDNS hostname with the port (28967 in your case), for example:

-e \

I would like to recommend to check everything from this check-list:

I have decided to start from scratch. I did a fresh install, and have received a new identity auth token. I have plugged a USB drive into the raspberry pi, to back up the identity folder.

I am presently in the /root/.local/share/storj/identity/storagenode folder. I have a USB drive inserted, and it is listed as sdb1. (screenshot attached) it is a 2 GB USB stick called “STORJ”

What command do I type to copy the folder to the USB drive.

You should mount your disk first via /etc/fstab, make sure that it’s available after reboot, then create a folder on the disk and then create another two folders inside it - one for identity and the second - for storage.

And with folder for identity


You can read how to mount a disk here: How do I setup static mount via /etc/fstab for Linux? | Storj Docs
In your docker run you will specify the --mount type=bind,source=/mnt/storj/storagenode,destination=/app/config and --mount type=bind,source=/mnt/storj/storagenode/identity,destination=/app/identity

My disk UDID is 284a2782-1708-4012-b5e8-0abf4bfb472a

This is what I have when I follow the directions from

The last line looks like should not be there (^@^@...), please, remove it (stay on it and press Ctrl-K), then save the file (Ctrl-O) and exit the editor (Ctrl-X).

Have you created a folder /mnt/storj?
If so, please, execute

sudo mount -a

Then check disks:

df --si

I have edited the /etc/fstab (screenshot attached).

When I run $ sudo mount -a

mount: /mnt/storj: special device UDID=284a2782-1708-4012-b5e8-0abf4bfb472a does not exist.

Please, try to check devices:


Also, it should be UUID not UDID

It was the typo! UUID fixed it.

Ok, the newest problem that exists. Here is what I have. I am lost on how to fix it.

There is nothing to fix.
You are under the root, so the path to that folder is looks like /root/.local/share/storj/identity/storagenode
If you want to have it in the /home/pi/.local/share/storj/identity/storagenode, then you should move it to there.
And do not forget to update your docker run command accordingly.

However, as I said earlier, it’s better to move it to the /mnt/storj/storagenode/identity. The SD card is not robust and can die. In that case you will just buy another one, flash the OS on it, install the docker and run the prepared script to start the node.

As I mentioned before, I am very poor with command line stuff. I really don’t know how to move things around. I do have a USB inserted ready to copy things over. How is the easiest way to do that? (what commands)

I also cannot get the dashboard up. I checked out the Failed to load identity - node keeps restarting - #3 by ntotao thread. I followed the instructions. My external IP address shows different that my WAN IP. I am baffled as to why.

Because your ISP placed you behind their NAT.
You have a three options:

  1. Ask your current ISP how can you receive a public IP, it can be dynamic, but must be a public;
  2. Switch to other ISP who offer the public IP;
  3. Use VPN services with port forwarding options such as, ngrok, PIA, PureVPN, etc.

I figured they had done that. I had them remove me outside the garrier grade NAT in the past, but I am guessing they have put me back inside. I just called and chewed them out (Thailand ISP). Out of every ten times you call them, they might fix your problems once. Otherwise the service is good 1Gbps/500Mbps for about $28 USD a month.

Now, I just have to figure out the backup of those folders. I am working on it!