Storage node Setting Up Error

Hi to everyone, during the last few days I’ve tried to start a node (1st time for me).
I’ve done every step succesfully until was the moment to setting up the node.

I have modified the command to paste in the terminal window accordingly to the instructions
(for example “docker run --rm -e SETUP=“true” --mount type=bind,source=“C:\xxxxx\xxxxxx\AppData\Roaming\Storj\Identity\storagenode”,destination=/app/identity --mount type=bind,source=“D:\Storj”,destination=/app/config --name storagenode storjlabs/storagenode:latest”)

When I paste the command in Powershell it gives me this error:
" Error response from daemon: invalid mount config for type “bind”: invalid mount path: ‘/app/identity’.
See ‘C:\Program Files\Docker\Docker\Resources\bin\docker.exe run --help’."

What should I do for resolve this?

Thanks to everyone who can spend one moment for me.

Welcome to the forum @Davide998 !

Can you confirm that you are not using curly quotes ? They should be ". Use an editor like notepad++

Hi @nerdatwork , for editing the command I’m using notepad++.
What do you mean for curly quotes?

" compared to - one is straight, the other curly. The run command should use the straight quotes.

Hi @Stob , thank you for your answer, sometimes it’s hard for me to understand well in english…
BTW yes, I’m using straight quotes.

Hi Davide,

Could you please post your docker run command (with identifying information removed)? Please post the command between three backticks ( ``` ) on the line above and below the block of text to keep the formatting. This will help check for errors.

Hi @baker , here’s the command:

docker run --rm -e SETUP="true" --mount type=bind,source="identity dir",destination=/app/identity --mount type=bind,source="storage dir",destination=/app/config --name storagenode storjlabs/storagenode:latest

P.S.: I’ve copied the command directly from the node operator start up procedure

Okay. Are you using WSL on this windows machine? Or docker desktop? Typically Windows GUI is recommended in these cases.

You should edit that post and include the actual path to the folders so we can diagnose.

@baker , I’m using Docker desktop.

@nerdatwork here the complete command (I just hide some folders name for privacy, but the path is the same):

docker run --rm -e SETUP="true" --mount type=bind,source="C:\xxxx\xxxxx\AppData\Roaming\Storj\Identity\storagenode",destination=/app/identity --mount type=bind,source="D:\Storj",destination=/app/config --name storagenode storjlabs/storagenode:latest

I am unsure how to use docker from the command line in Windows. However, you could try changing the single backslashes to double back slashes in your paths.

docker run --rm -e SETUP="true" --mount type=bind,source="C:\\xxxx\\xxxxx\\AppData\\Roaming\\Storj\\Identity\\storagenode",destination=/app/identity --mount type=bind,source="D:\\Storj",destination=/app/config --name storagenode storjlabs/storagenode:latest

My suggestion if this doesn’t work would be to use the docker GUI to set up your mounts first, or if you have no specific need to run docker, switch to the Windows GUI version of Storj.

Have you shared both C and D drives inside Docker desktop ?

@baker thank you, unfortunately the command still not work.
I have no need to use docker, if doesn’t work, I can switch to Windows GUI.

@nerdatwork I’ve done nothing with docker desktop, what should I do for sharing both drives ?

Right click docker desktop icon in system tray. Go to Settings. Click Shared drives on the left. Check boxes next to C and D as you are storing identity in C and data in D.


Save and then execute the command.

MMH maybe I have some problems… I don’t have the Shared Drive page! :sweat_smile:

What is your docker desktop version ? Which Windows are you using ?

Docker version is
I’m using windows 10 Pro

Try these steps.

Then just do that now. It takes 5 minutes and is the preferred way of running a Storj node on Windows.

You don’t need a new identity or anything, just install the GUI version and pick your identity + storage path.