Storagenode not starting

I noticed today my storagenode got offline around an hour ago. I have tried removing and pulling a new docker image. Still doesn’t work. The node is 2 months old. My 4TB Harddrive is 2.5 months old and doubles as a storage fr my media server. I tested and the hardrive works fine. But the storagenode logs says some Io problem. Please help.

Welcome to the forum @4llonsy!

How is your HDD connected ? Is it Linux or Windows setup ?

Linux setup, using fstab. Ntfs formatted drive.

You should use ext4 for linux nodes.

Is it a connected via USB or Sata ?

Usb gen 3. Connected to raspi 4 4GB

You can try to fix this disk with a fsck. You should stop and remove the container and unmount this disk, then check and mount back.
After the check try to run a storagenode and check your logs.
If after the check the error is still persist, then you should disconnect this drive and check it on Windows.

Consider to format this drive to ext4 as soon as possible. For that you will need to backup the data to somewhere and then return back after format to the ext4.