Storagenode on windows not working

I keep getting those errors

2020-05-20T22:21:18.211+0100 FATAL Failed preflight check. {“error”: “system clock is out of sync: system clock is out of sync with all trusted satellites”, “errorVerbose”: “system clock is out of sync: system clock is out of sync with all trusted satellites\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check:96\n\tstorj.io/storj/storagenode.(*Peer).Run:700\n\tmain.cmdRun:200\n\tstorj.io/private/process.cleanup.func1.4:343\n\tstorj.io/private/process.cleanup.func1:361\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:945\n\tgithub.com/spf13/cobra.(*Command).Execute:885\n\tstorj.io/private/process.ExecWithCustomConfig:86\n\tstorj.io/private/process.Exec:63\n\tmain.(*service).Execute.func1:66\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}

my time is up to date
image

Do you have windows GUI or doker on windows?

Is your time in sync? Also check your timezone.

he posted picture from Nettime, it show that is synced.

ok so I had my internet changed today and it looks like I’m behind CGNAT… so probably that is the issue… it shows something else in logs but the main issue is that there is no connection from outside…

Set your update interval to 15 mins under settings.

ok managed to set everything up now on public IP
set update every 15 min @nerdatwork

still no joy…
2020-05-22T14:30:28.829+0200 FATAL Failed preflight check. {“error”: “system clock is out of sync: system clock is out of sync with all trusted satellites”, “errorVerbose”: “system clock is out of sync: system clock is out of sync with all trusted satellites\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check:96\n\tstorj.io/storj/storagenode.(*Peer).Run:700\n\tmain.cmdRun:200\n\tstorj.io/private/process.cleanup.func1.4:343\n\tstorj.io/private/process.cleanup.func1:361\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:945\n\tgithub.com/spf13/cobra.(*Command).Execute:885\n\tstorj.io/private/process.ExecWithCustomConfig:86\n\tstorj.io/private/process.Exec:63\n\tmain.(*service).Execute.func1:66\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}

GUI Windows.
got 2 other nodes on docker on synology working well on new version (different location, IP’s etc)

Can you confirm nettimesvc service is running? Also just to double check try to Right click system time ->Adjust date/time -> click Sync Now. Then restart storagenode service.

Can you also try turn off windows firewall for some time, may be it blokking for out comunication.

all working… restarted etc…

done. still the same…

ok so I went through this list:
image

all of those satellites reply to a ping from that windows machine…

In that case you have a three options:

  • talk with your current ISP and ask how to obtain a public IP, it could be dynamic, but must be a public (your WAN IP will match the IP from the https://www.yougetsignal.com/tools/open-ports/);
  • switch the ISP to the one with a public IP option;
  • use a VPN services with a port forwarding option, such as PIA, portmap.io, ngrok, PureVPN, etc.

Is the option to mount another node using a vpn like purevpn for example valid?

Why you need that?
Just run a second node with the same public address but with a different port.
Any VPN will add a latency and reduce the possibility to win the piece in the race.
The VPN is needed when you unable to get a public IP directly.

1 Like

I had this doubt about the vpn, because in several threads of the forum, they talked about using vpn for their nodes and in other threads they mentioned that they could put several nodes with the same ip.

Now that you have explained it to me well, I think I have no more doubts on the subject. Thank you very much for answering.

2 Likes

well I dont want add more latency to be honest… the issue with CGNAT is solved already.

port forwarding and so on is setup and working. The original issue is still there. I’m starting to think that it’s an issue with one of the latest windows 10 updates as all the settings are ok and services…

Have you checked the port on https://www.yougetsignal.com/tools/open-ports/ with your configured external address and port?

yes ports are opened.
new windows install. still the same issue:
2020-05-25T17:22:10.804+0100 INFO Telemetry enabled
2020-05-25T17:22:10.894+0100 INFO db.migration Database Version {“version”: 39}
2020-05-25T17:22:11.571+0100 INFO preflight:localtime start checking local system clock with trusted satellites’ system clock.
2020-05-25T17:22:31.571+0100 ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “121RTSDpyNZVcEU84Ticf2L1ntiuUimbWgfATz21tuvgk3vzoA6”, “error”: “rpccompat: dial tcp 34.80.94.151:7777: i/o timeout”, “errorVerbose”: “rpccompat: dial tcp 34.80.94.151:7777: i/o timeout\n\tstorj.io/common/rpc.Dialer.dialTransport:279\n\tstorj.io/common/rpc.Dialer.dial:256\n\tstorj.io/common/rpc.Dialer.DialAddressID:166\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-05-25T17:22:31.571+0100 ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “118UWpMCHzs6CvSgWd9BfFVjw5K9pZbJjkfZJexMtSkmKxvvAW”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:279\n\tstorj.io/common/rpc.Dialer.dial:256\n\tstorj.io/common/rpc.Dialer.DialAddressID:166\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-05-25T17:22:31.572+0100 ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “1wFTAgs9DP5RSnCqKV1eLf6N9wtk4EAtmN5DpSxcs8EjT69tGE”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:279\n\tstorj.io/common/rpc.Dialer.dial:256\n\tstorj.io/common/rpc.Dialer.DialAddressID:166\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-05-25T17:22:31.571+0100 ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:279\n\tstorj.io/common/rpc.Dialer.dial:256\n\tstorj.io/common/rpc.Dialer.DialAddressID:166\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-05-25T17:22:31.571+0100 ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “12L9ZFwhzVpuEKMUNUqkaTLGzwY9G24tbiigLiXpmZWKwmcNDDs”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:279\n\tstorj.io/common/rpc.Dialer.dial:256\n\tstorj.io/common/rpc.Dialer.DialAddressID:166\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-05-25T17:22:31.572+0100 ERROR preflight:localtime unable to get satellite system time {“Satellite ID”: “12rfG3sh9NCWiX3ivPjq2HtdLmbqCrvHVEzJubnzFzosMuawymB”, “error”: “rpccompat: context deadline exceeded”, “errorVerbose”: “rpccompat: context deadline exceeded\n\tstorj.io/common/rpc.Dialer.dialTransport:279\n\tstorj.io/common/rpc.Dialer.dial:256\n\tstorj.io/common/rpc.Dialer.DialAddressID:166\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).getSatelliteTime:110\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check.func1:67\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}
2020-05-25T17:22:31.572+0100 FATAL Failed preflight check. {“error”: “system clock is out of sync: system clock is out of sync with all trusted satellites”, “errorVerbose”: “system clock is out of sync: system clock is out of sync with all trusted satellites\n\tstorj.io/storj/storagenode/preflight.(*LocalTime).Check:96\n\tstorj.io/storj/storagenode.(*Peer).Run:695\n\tmain.cmdRun:200\n\tstorj.io/private/process.cleanup.func1.4:359\n\tstorj.io/private/process.cleanup.func1:377\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:945\n\tgithub.com/spf13/cobra.(*Command).Execute:885\n\tstorj.io/private/process.ExecWithCustomConfig:88\n\tstorj.io/private/process.Exec:65\n\tmain.(*service).Execute.func1:66\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:57”}

even started to look at the quality of the internet connection… and I do see timeout on time.windows.com

new windows 10, new identity. it’s def a network issue with my ISP
when trying to authorize new identity through powershell
Error: rpccompat: context deadline exceeded

when I will talk to my ISP how do I even start the conversation? what should I tell them? that I cannot sync time with microsoft servers? ehh…