Two different nodes on same local network

Hello Everyone!
I have a working node for 6 month already, it is running fine, I’m happy with it.
It is running on an HP N40L Microserver with Windows 8.1. I started it with an external 1TB HDD. When it was filled up, I moved it to a dedicated internal 4TB drive. The node has good stats, it is filling up nicely. It is using the default ports, port 28967 forwarded properly from external network to the N40L’s dedicated local IP (192.168.10.50).
I was thinking about to set up an other node next to the N40L as I can not run multiple nodes on the same machine due to Windows. The N40L is used for other tasks as well, so I would like to keep it as a Windows machine…
The second node would be a RPi 3B+ 64bit with a 2TB external HDD. Since it is a dedicated machine, it has it’s own dedicated internal IP (192.168.10.99). I set up port forwarded of port 28968 to this IP in my router.
I requested new auth token which I got on screen, but never received by e-mail (the email address is valid/working, I use it every day and it is the same as for the first node).

I installed Raspbian 32bit using the rPi image creator.
Generated identity with success, authorized the identity and have the confirmation based on the guide.
Installed Docker based on the guide with the convenience script.
Installed the storage node docker container with -p 28968:28967.
Everything seems fine and according to all the guides.

However, when I start the storagenode, it is keep restarting itself in every 60 sec, I see it if I use the docker ps -a command to check the status. Also the dashboard is not available at 192.168.10.99:14002 address.

I installed the watchtower container and it is running fine, I see “UP …”

I was checking if the port 28968 is opened, but the check is saying that it is closed, while with the same kind of port forward the 28967 is opened (used by the other node).

I tried to to do everything once again by deleting containers, docker and reinstalling these, but the result is the same.

Is there anything what I missed…? :frowning:

A couple of thoughts:

You could run docker on Windows or use the Toolbox for multiple nodes on the same Windows computer.

Ideally we need to see the log files for this, but some others had the same issue as there is now a -setup required on first run of the storagenode.

4 Likes

Why not Windows 10 ?

I totally missed that :astonished:

Windows 10 is a free upgrade from 8.1

1 Like

Well… it is running without ANY issue for many years now. Basically a file server for the family + torrent, can be managed throught remote desktop / teamviewer. There was no any single reason for the upgrade.

Don’t wait for a malware to find loophole in 8.1. I would strongly recommend to upgrade to Win 10 if it is supported. At first you might hate it but it’s “better” than 8.1.
image

Show your docker run command for 2nd node.

1 Like

Actually, Windows 8.1 is still supported.
“Windows 8.1 reached the end of Mainstream Support on January 9, 2018, and will reach end of Extended Support on January 10, 2023”

Just to add

Safari is a great example for Windows. It was last updated in 2015, today it still works but not all websites work on it. Ex: None of Storj & related websites would work on Safari for Windows.

Officially Storj is supported for Windows 8 and above but I would still strongly recommend to use Windows 10 instead.

1 Like

Ok, so here are some more precise details:

I run the setup with this command:
docker run --rm -e SETUP=“true”
–mount type=bind,source="/mnt/storage/storj/identity",destination=/app/identity
–mount type=bind,source="/mnt/storage/storj/storage",destination=/app/config
–name storagenode storjlabs/storagenode:latest

Following this, I started the container/node with this (some xxx to hide sensitive data…):
docker run -d --restart unless-stopped --stop-timeout 300 \
-p 28968:28967
-p 14002:14002
-e WALLET=“0x348D064c8xxxxxxxxxxxxxxxxxxxx”
-e EMAIL="xxxxxx@hotmail.com"
-e ADDRESS=“xxxxxx.mydyndns.me:28968
-e STORAGE=“1.7TB”
–mount type=bind,source="/mnt/storage/storj/identity",destination=/app/identity
–mount type=bind,source="/mnt/storage/storj",destination=/app/config
–name storagenode storjlabs/storagenode:latest

Following this, I see these status messages:

The paths you use with the setup command should be identical to the paths you intend to use in your standard docker run command.

Where does it state that? I thought official support was for Windows 10 only

Corrected in the standard docker run command, but result is the same. it is keep restarting… :frowning:

Are you sure it’s not /mnt/storage/storj/identity/storagenode ?

https://documentation.storj.io/before-you-begin/prerequisites

1 Like

There must be some error messages in the logs that should indicate what the problem might be.

Yes, you are right. So I did checked it… and it turned out that I made a typo in the external address…
I’m sorry for wasting everyones time… :woozy_face:

3 Likes

No problem! Sometimes it takes working through a problem with others even if the cause was a simple typo. Glad you got it going!

4 Likes

I don’t really agree. A browser by its very nature is going to come across a lot of variations in sites. By what was said previously the Windows install here is used for fixed purposes only and not a daily driver so the variation encountered is not likely to be that high. That said, I only maintain a Windows 8.1 VM myself for testing purposes and don’t actually use it for anything anymore. However, i still find it performs faster on lower hardware than Windows 10 does. I can literally run a win 10 VM and Win 8 VM on exactly the same hardware and the Win 8.1 VM outperforms Win 10 easily.

should be

--mount type=bind,source="/mnt/storage/storj",destination=/app/config \

or both commands (with SETUP and without) should point to

--mount type=bind,source="/mnt/storage/storj/storage",destination=/app/config \

And also, make sure that you do not use any word processors to form the docker run command, they often replaces double dashes -- to hyphen and straight quotes " to curly ones and , those symbols are invalid for the shell.

Unfortunately not:


because of

Thank you Alexey for the clarification. You are right, this was my mistake. As I wrote, the main issue was a typo in the external address, since I corrected these, the node is running fine.

On the other hand, I noticed that the config.yaml file of the docker node has many missing information compared to the windows node (e-mail, wallet, storage directory, storage capacity, etc… lines are either with “” or starting with #. Is it normal? The node is working and using these informations based on the docker run command.