Uplink does not show objects, RClone & FileZilla do

I am experiencing a very strange Issue. A couple of months back I uploaded some files using RClone. Now, I tried to access my bucket using the same access grant (on initially a new computer) using Uplink. I tried both uplink access import and uplink access create and then even ran uplink access use. I could not see my files. Went back to old computer, again the same behaviour. Setup the account then on FileZilla and there I can see my files. Help?

Hello @CxRes,
Welcome to the forum!

To see a previous objects you need to use exactly the same encryption phrase used during upload. If you would use a different encryption phrase, your buckets will look like empty (we do not show not decryptable objects).
You may generate a new access grant with your encryption phrase for these objects (each object may be encrypted by own encryption phrase, but to see them you need to use their encryption phrase), and import this new access grant to uplink or rclone.

Could you please check, when you created the access grant, used in uplink/rclone before?

1 Like

Hello Alexey, Thanks for your response.

Unfortunately, I am only able to verify one thing and not the other.

If I create a new key using the original passphrase, I am able to access the objects as you say, but with RClone and FileZilla.

Unfortunately, I am having troubles with Uplink:

  1. I am unable to create a new access using an access grant. When I run Uplink access setup on the question Enter API key or Access grant, I am unable to enter full Access Grant. The access grant is truncated 2/3rds of the way and I cannot enter more characters.
  2. So instead I create a new access using the API key, satellite and the original passphrase (on which I have verified access with RClone). However, running Uplink ls <bucket> now turns up empty.

Perhaps, there is a bug in Uplink?

I am on Window 10 x64, using Powershell

Uplink version says:

Release build
Version:            v1.63.1
Build timestamp:    01 Sep 22 22:56 IST
Git commit:         9a4a03d746c522d390ca97363b3aa7813e2dc39e

PATH                      VERSION
storj.io/storj            (devel)
storj.io/common           v0.0.0-20220822090045-1b57fc2bbda1
storj.io/drpc             v0.0.32
storj.io/monkit-jaeger    v0.0.0-20220726162929-c3a9898b5bca
storj.io/private          v0.0.0-20220818074142-c354e3e64dd3
storj.io/uplink           v1.9.1-0.20220811092921-37dccde06f31

If you use setup command, then you need to create an API key instead of access grant. You then will be requested to provide an encryption phrase and it should match the phrase used for access grant in the UI for rclone or FileZilla.
However, if you did setup before, there is likely a previous access with the same name and the setup command will not allow you to replace it, you need to use --force flag in addition.

To import the pre-generated access grant to uplink you may use the uplink access import command.
The rule for replacing the existing access to a new one with the same name - either use a different name or replace the current one using --force flag.
If you provided a different name for the access rather than main, then you likely need to either to select it with uplink access use command, or specify the name of the access in each command, i.e.

uplink ls --access new-access sj://my-bucket
1 Like

@Alexey Thanks for the solution!

To import the pre-generated access grant to uplink you may use the uplink access import command.

Just a pedantic point. The access grant generated in the dashboard for download is in the format access grant: <access grant>. However import expects a file that just contains the access grant and nothing else, which tripped me at first with a uplink: invalid access grant format message.