Using Storj DCS as Pixelfed Storage

nginx: [emerg] a duplicate default server for in /etc/nginx/sites-enabled/default:137

Okay … it’s working now … Had remove default_server …

Previously I was using https for proxy pass…

Real problem begins here…

I’ve generated a share link from MinIo dashboard …
Which is …"public%2Fm%2F_v2%2F500703548553293836%2Fa48ad3dc0-89cf68%2FTRjdjeyXvCQj%2FzDeeOjjaKNKyIINlZVcRCH5CoOBJpOtnphfysgAs.jpg"&X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=P4id2MjwQLioEWjNeASQBTjWdKP%2F20221127%2F%2Fs3%2Faws4_request&X-Amz-Date=20221127T135958Z&X-Amz-Expires=432000&X-Amz-SignedHeaders=host&X-Amz-Signature=75fa871b70254ba3a022abc7504987d191ad6dad808e7597cfeea88a05f85c22

After visiting the url … I get following

Anything wrong with my setup ? Btw , I can’t upload anything from Pixelfed …

I’ve already tried with Aws URL … but no luck

NB : I uploaded files directly from MinIo dashboard… … Still getting same error

Please update your location section to modify headers for presigned URLs: Set up Nginx proxy with MinIO Server — MinIO Object Storage for Linux,

location / {
   proxy_set_header X-Real-IP $remote_addr;
   proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
   proxy_set_header X-Forwarded-Proto $scheme;
   proxy_set_header Host $http_host;

   proxy_connect_timeout 300;
   # Default is HTTP/1, keepalive is only enabled in HTTP/1.1
   proxy_http_version 1.1;
   proxy_set_header Connection "";
   chunked_transfer_encoding off;


You may also find a useful recommendations there.

1 Like

Okay :+1: :ok_hand:… It’s working … Now I can Upload photos … but not getting any preview …

The problem is …

Any way to get through this ?

Dansup (Daniel) is the main developer of Pixelfed …

Also If this visit this url

It’s Redirecting me to MinIO dashboard… Which it shouldn’t

Losing my mind now … :slightly_smiling_face:

I need to set the bucket public … right ?

Should I enter my Access Id generated by GatewayST after --access?

You need to run GatewayST in website mode, see Gateway ST Advanced Usage - Storj DCS Docs

1 Like

Is there any problem if I run with default access grant ?

Okay … Now I can access direct links … But suddenly my site isn’t responding :confused:… Server is up and running